From: Andrew Morton <akpm@linux-foundation.org>
To: balbir@linux.vnet.ibm.com
Cc: Peter Zijlstra <peterz@infradead.org>,
Hugh Dickins <hugh@veritas.com>,
Dave Hansen <haveblue@us.ibm.com>,
LKML <linux-kernel@vger.kernel.org>
Subject: Re: [PATCH] Move page_assign_page_cgroup to VM_BUG_ON in free_hot_cold_page
Date: Thu, 20 Dec 2007 09:12:15 -0800 [thread overview]
Message-ID: <20071220091215.a87d2588.akpm@linux-foundation.org> (raw)
In-Reply-To: <476A972F.6050904@linux.vnet.ibm.com>
On Thu, 20 Dec 2007 21:54:15 +0530 Balbir Singh <balbir@linux.vnet.ibm.com> wrote:
> >> struct page_cgroup *page_get_page_cgroup(struct page *page)
> >> {
> >> return (struct page_cgroup *)
> >> (page->page_cgroup & ~PAGE_CGROUP_LOCK);
> >> }
> >>
> >> I guess the issue is that often a "get" function has a complementary
> >> "put" function, but this isn't one of them. Would page_page_cgroup
> >> be a better name, perhaps? I don't know.
> >
> > Ah, yes, I mistakenly assumed it was a reference get. In that case I
> > stand corrected and do not have any objections.
> >
>
> I was going to say the same thing, page_get_page_cgroup() does not hold
> any references. May be _get_ in the name is confusing.
It is a bit unconventional. page_cgroup()?
next prev parent reply other threads:[~2007-12-20 17:13 UTC|newest]
Thread overview: 11+ messages / expand[flat|nested] mbox.gz Atom feed top
2007-12-19 6:18 Balbir Singh
2007-12-19 17:14 ` Dave Hansen
2007-12-20 13:14 ` Hugh Dickins
2007-12-20 13:51 ` Peter Zijlstra
2007-12-20 14:16 ` Hugh Dickins
2007-12-20 14:20 ` Peter Zijlstra
2007-12-20 16:24 ` Balbir Singh
2007-12-20 16:35 ` Dave Hansen
2007-12-20 17:12 ` Andrew Morton [this message]
2007-12-20 17:21 ` Hugh Dickins
2007-12-20 17:39 ` Balbir Singh
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20071220091215.a87d2588.akpm@linux-foundation.org \
--to=akpm@linux-foundation.org \
--cc=balbir@linux.vnet.ibm.com \
--cc=haveblue@us.ibm.com \
--cc=hugh@veritas.com \
--cc=linux-kernel@vger.kernel.org \
--cc=peterz@infradead.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
Powered by JetHome