From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1757532AbYAHGPe (ORCPT ); Tue, 8 Jan 2008 01:15:34 -0500 Received: (majordomo@vger.kernel.org) by vger.kernel.org id S1754742AbYAHGPX (ORCPT ); Tue, 8 Jan 2008 01:15:23 -0500 Received: from rhun.apana.org.au ([64.62.148.172]:4437 "EHLO arnor.apana.org.au" rhost-flags-OK-OK-OK-FAIL) by vger.kernel.org with ESMTP id S1754551AbYAHGPW (ORCPT ); Tue, 8 Jan 2008 01:15:22 -0500 Date: Tue, 8 Jan 2008 17:15:16 +1100 From: Herbert Xu To: WANG Cong Cc: LKML , David Miller , netdev@vger.kernel.org Subject: Re: [Patch] xfrm_policy_destroy: rename and relative fixes Message-ID: <20080108061516.GD2529@gondor.apana.org.au> References: <20080103120550.GB2498@hacking> Mime-Version: 1.0 Content-Type: text/plain; charset=us-ascii Content-Disposition: inline In-Reply-To: <20080103120550.GB2498@hacking> User-Agent: Mutt/1.5.9i Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org On Thu, Jan 03, 2008 at 08:05:50PM +0800, WANG Cong wrote: > > Since __xfrm_policy_destroy is used to destory the resources > allocated by xfrm_policy_alloc. So using the name > __xfrm_policy_destroy is not correspond with xfrm_policy_alloc. > Rename it to xfrm_policy_destroy. > > And along with some instances that call xfrm_policy_alloc > but not using xfrm_policy_destroy to destroy the resource, > fix them. > > Cc: David Miller > Cc: Herbert Xu > Signed-off-by: WANG Cong This patch looks OK to me. Thanks, -- Visit Openswan at http://www.openswan.org/ Email: Herbert Xu ~{PmV>HI~} Home Page: http://gondor.apana.org.au/~herbert/ PGP Key: http://gondor.apana.org.au/~herbert/pubkey.txt