From: Sam Ravnborg <sam@ravnborg.org>
To: Bartlomiej Zolnierkiewicz <bzolnier@gmail.com>
Cc: Sergei Shtylyov <sshtylyov@ru.mvista.com>,
LKML <linux-kernel@vger.kernel.org>,
linux-ide@vger.kernel.org
Subject: Re: [Fixed PATCH] hpt366: fix section mismatch warnings
Date: Sun, 24 Feb 2008 18:53:15 +0100 [thread overview]
Message-ID: <20080224175315.GA10712@uranus.ravnborg.org> (raw)
In-Reply-To: <200802241533.51671.bzolnier@gmail.com>
On Sun, Feb 24, 2008 at 03:33:51PM +0100, Bartlomiej Zolnierkiewicz wrote:
> On Saturday 23 February 2008, Sam Ravnborg wrote:
> > hpt366: fix section mismatch warnings
> >
> > Fix following warnings:
> > WARNING: o-sparc64/vmlinux.o(.data+0x195a38): Section mismatch in reference from the variable hpt37x_info.0 to the variable .devinit.data:hpt370
> > WARNING: o-sparc64/vmlinux.o(.data+0x195a40): Section mismatch in reference from the variable hpt37x_info.0 to the variable .devinit.data:hpt370a
> > WARNING: o-sparc64/vmlinux.o(.data+0x195a48): Section mismatch in reference from the variable hpt37x_info.0 to the variable .devinit.data:hpt372
> > WARNING: o-sparc64/vmlinux.o(.data+0x195a50): Section mismatch in reference from the variable hpt37x_info.0 to the variable .devinit.data:hpt372n
> >
> > Replace a static array with a small switch resulting in
> > more readable code.
> > Mark the pci table __devinitconst.
> >
> > A lot of variables are const but annotated __devinitdata.
> > Annotating them __devinitconst would cause a section type
> > conflict error when build for 64 bit powerpc.
> >
> > Signed-off-by: Sam Ravnborg <sam@ravnborg.org>
> > Cc: Bartlomiej Zolnierkiewicz <bzolnier@gmail.com>
> > Cc: Sergei Shtylyov <sshtylyov@ru.mvista.com>
> > ---
>
> thanks, applied
>
> > The first patch I posted caused a section type conflict when
> > build for 64 bit powerpc. The actual cause of this is know and unavoidable
> > when we start to declare variables const.
> > The patch attached is much simpler as the transition from __devinitdata
> > to __devinitconst turned out to be bogus.
>
> Weird, I thought that the main purpose of __devinitconst was to replace
> const + __devinitdata?
The problem we face is that gcc in some cases mark the
destination section READ-ONLY and in other cases not.
So if we annotate two variables to go into the same
section and gcc only annotate one of them READ-ONLY them
we will have a section type conflict.
gcc is not consistent across architectures what to mark
READ-ONLY and not. And what we saw here was a combination
where on x86 the destinatin section were marked equal
(READ-ONLY or not READ-ONLY) but on powerpc were marked
different. One was marked READ-ONLY the other was not.
So when playing with const it is improtant to try out with
a 64 bit gcc for powerpc to see if it causes any section
type conflict. Note: 32 bit gcc does not have this
issue.
Sam
prev parent reply other threads:[~2008-02-24 17:53 UTC|newest]
Thread overview: 7+ messages / expand[flat|nested] mbox.gz Atom feed top
2008-02-22 19:46 [PATCH] " Sam Ravnborg
2008-02-22 19:53 ` Sergei Shtylyov
2008-02-22 20:57 ` Bartlomiej Zolnierkiewicz
2008-02-22 20:43 ` Sam Ravnborg
2008-02-23 21:22 ` [Fixed PATCH] " Sam Ravnborg
2008-02-24 14:33 ` Bartlomiej Zolnierkiewicz
2008-02-24 17:53 ` Sam Ravnborg [this message]
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20080224175315.GA10712@uranus.ravnborg.org \
--to=sam@ravnborg.org \
--cc=bzolnier@gmail.com \
--cc=linux-ide@vger.kernel.org \
--cc=linux-kernel@vger.kernel.org \
--cc=sshtylyov@ru.mvista.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®