From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1756217AbYDRCAp (ORCPT ); Thu, 17 Apr 2008 22:00:45 -0400 Received: (majordomo@vger.kernel.org) by vger.kernel.org id S1753140AbYDRCAf (ORCPT ); Thu, 17 Apr 2008 22:00:35 -0400 Received: from 206-248-169-182.dsl.ncf.ca ([206.248.169.182]:27161 "EHLO phobos.cabal.ca" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1753106AbYDRCAe (ORCPT ); Thu, 17 Apr 2008 22:00:34 -0400 Date: Thu, 17 Apr 2008 22:00:33 -0400 From: Kyle McMartin To: Roland McGrath Cc: Andrew Morton , Linus Torvalds , linux-kernel@vger.kernel.org Subject: Re: [PATCH] ptrace_signal subroutine Message-ID: <20080418020033.GI23641@phobos.i.cabal.ca> References: <20080418014438.1C93C27037D@magilla.localdomain> MIME-Version: 1.0 Content-Type: text/plain; charset=us-ascii Content-Disposition: inline In-Reply-To: <20080418014438.1C93C27037D@magilla.localdomain> User-Agent: Mutt/1.5.17 (2007-11-01) Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org On Thu, Apr 17, 2008 at 06:44:38PM -0700, Roland McGrath wrote: > This breaks out the ptrace handling from get_signal_to_deliver > into a new subroutine. The actual code there doesn't change, and > it gets inlined into nearly identical compiled code. This makes > the function substantially shorter and thus easier to read, and > it nicely isolates the ptrace magic. > > Signed-off-by: Roland McGrath Nice clean up. cheers, Kyle