mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Arjan van de Ven <arjan@infradead.org>
To: Andrew Morton <akpm@linux-foundation.org>
Cc: linux-kernel@vger.kernel.org, mingo@elte.hu
Subject: Re: [patch 13/17] Use WARN() in drivers/base/
Date: Fri, 11 Jul 2008 15:35:58 -0700	[thread overview]
Message-ID: <20080711153558.5b79986a@infradead.org> (raw)
In-Reply-To: <20080711151110.ab2b5401.akpm@linux-foundation.org>

On Fri, 11 Jul 2008 15:11:10 -0700
Andrew Morton <akpm@linux-foundation.org> wrote:

> On Fri, 11 Jul 2008 13:54:09 -0700 Arjan van de Ven
> <arjan@infradead.org> wrote:
> 
> > On Fri, 11 Jul 2008 12:20:11 -0700
> > Andrew Morton <akpm@linux-foundation.org> wrote:
> > 
> > > On Tue, 8 Jul 2008 09:53:07 -0700 Arjan van de Ven
> > > <arjan@infradead.org> wrote:
> > > 
> > > > Signed-off-by: Arjan van de Ven <arjan@linux.intel.com>Index:
> > > > linux.trees.git/drivers/base/core.c
> > > 
> > > A number of these patches had mangled signed-off-by: lines.
> > > 
> > > Please try to be consistent in the presence and placement of the
> > > ^--- line at the end of the changelog.
> > > 
> > > I verified that all three copies of "Use WARN() in fs/" were the
> > > same.
> > > 
> > > I've decided that I don't like the whole thing :(  This:
> > > 
> > > #define WARN(condition, format...)
> > > ({					\ int __ret_warn_on
> > > = !!(condition);				\ if
> > > (unlikely(__ret_warn_on))					\
> > > __WARN_printf(format);					\
> > > unlikely(__ret_warn_on);
> > > \ })
> > > 
> > > is not a WARN().  It is a WARN_ON() function.  The use of this
> > > name now leaves us no sensible name under which to implement
> > > 
> > 
> > I'm totally open to a better name.
> > Having a condition in there is really nice, it means we can fold the
> > if() into it in many cases. Just like BUG_ON() did.
> 
> Alexey's WARN_IF() would suit, I guess.  Plain old "WARN" is just
> wrong here, alas.
> 
> I can just edit all the diffs if we're all OK with that.

I'm ok with that.

> 
> 
> 
> I don't suppose there's any way of tricking the preprocessor into
> supporting
> 
> 	WARN_ON(foo == 42);
> 
> as well as
> 
> 	WARN_ON(foo == 42, "bite me!");

there might be some obscure GCC extensions, but to be honest I fear the
worst ;(


-- 
If you want to reach me at my work email, use arjan@linux.intel.com
For development, discussion and tips for power savings, 
visit http://www.lesswatts.org

  reply	other threads:[~2008-07-11 22:36 UTC|newest]

Thread overview: 40+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2008-07-08 16:38 [patch 0/17] Series to introduce WARN()... a WARN_ON() variant that takes printk arguments Arjan van de Ven
2008-07-08 16:39 ` [patch 1/17] Clear the WARN() namespace Arjan van de Ven
2008-07-11 19:19   ` Andrew Morton
2008-07-08 16:40 ` [patch 2/17] Add a WARN() macro that acts like WARN_ON()+printk Arjan van de Ven
2008-07-08 18:00   ` Joe Perches
2008-07-08 18:18     ` Arjan van de Ven
2008-07-11 19:19   ` Andrew Morton
2008-07-11 20:51     ` Arjan van de Ven
2008-07-08 16:41 ` [patch 3/17] Introduce WARN() usage in the kobject code Arjan van de Ven
2008-07-08 16:42 ` [patch 4/17] Use WARN() in kernel/irq/manage.c Arjan van de Ven
2008-07-08 16:45 ` [patch 5/17] Use WARN() in kernel/panic.c Arjan van de Ven
2008-07-08 16:46 ` [patch 6/17] Use WARN() in mm/vmalloc.c Arjan van de Ven
2008-07-08 16:47 ` [patch 7/17] use WARN() in kernel/lockdep.c Arjan van de Ven
2008-07-08 16:48 ` [patch 8/17] use WARN() in kernel/irq/chip.c Arjan van de Ven
2008-07-08 16:50 ` [patch 9/17] Use WARN() in arch/x86/mm/ioremap.c Arjan van de Ven
2008-07-08 16:51 ` [patch 10/17] use WARN() in arch/x86/mm/pageattr.c Arjan van de Ven
2008-07-08 16:51 ` [patch 11/17] Use WARN() in arch/x86/kernel Arjan van de Ven
2008-07-08 16:52 ` [patch 12/17] Use WARN() in block/ Arjan van de Ven
2008-07-08 16:53 ` [patch 13/17] Use WARN() in drivers/base/ Arjan van de Ven
2008-07-11 19:20   ` Andrew Morton
2008-07-11 20:54     ` Arjan van de Ven
2008-07-11 22:11       ` Andrew Morton
2008-07-11 22:35         ` Arjan van de Ven [this message]
2008-07-11 22:51         ` Arjan van de Ven
2008-07-11 23:02           ` Andrew Morton
2008-07-11 23:56             ` Arjan van de Ven
2008-07-11 23:10         ` Johannes Berg
2008-07-12  0:51           ` Johannes Berg
2008-07-08 16:53 ` [patch 14/17] Use WARN() in lib/ Arjan van de Ven
2008-07-08 16:54 ` [patch 15/17] Use WARN() in fs/ Arjan van de Ven
2008-07-08 16:54 ` Arjan van de Ven
2008-07-08 16:55 ` Arjan van de Ven
2008-07-08 16:56 ` [patch 16/17] Usr WARN() in fs/sysfs Arjan van de Ven
2008-07-08 16:57 ` [patch 17/17] Use WARN() in fs/proc/ Arjan van de Ven
2008-07-09 10:13 ` [patch 0/17] Series to introduce WARN()... a WARN_ON() variant that takes printk arguments Ingo Molnar
2008-07-09 11:19   ` Andrew Morton
2008-07-09 11:37     ` Ingo Molnar
2008-07-09 11:46       ` Andrew Morton
2008-07-09 12:13         ` Ingo Molnar
2008-07-09 13:31         ` Arjan van de Ven

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20080711153558.5b79986a@infradead.org \
    --to=arjan@infradead.org \
    --cc=akpm@linux-foundation.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=mingo@elte.hu \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

Powered by JetHome