From: Oleg Nesterov <oleg@tv-sign.ru>
To: Akinobu Mita <akinobu.mita@gmail.com>
Cc: akpm@linux-foundation.org, linux-kernel@vger.kernel.org
Subject: Re: + workqueue-proper-error-unwinding-in-cpu-hotplug-error-path.patch added to -mm tree
Date: Tue, 22 Jul 2008 14:23:54 +0400 [thread overview]
Message-ID: <20080722102354.GA1068@tv-sign.ru> (raw)
In-Reply-To: <20080722095539.GA6188@localhost.localdomain>
On 07/22, Akinobu Mita wrote:
>
> On Tue, Jul 22, 2008 at 01:16:36PM +0400, Oleg Nesterov wrote:
>
> > Can't we simplify the fix? I don't like the fact that the CPU_UP_CANCELED
> > logic is duplicated.
> >
> > What do you think about the patch below?
>
> Yes, it is no duplication. But the goto usage in this patch looks bit
> tricky to me.
Well, the kernel is full of "goto again" / "goto retry". Not that I
claim this patch improves the readability ;)
But the duplication is really bad, imho.
> Maybe it is better to factor out the list_for_each() block.
Not sure I understand... do you mean add another function which
starts with list_for_each_entry ? This is not necessary, instead
of goto we can just do
workqueue_cpu_callback(CPU_UP_CANCELED);
return NOTIFY_BAD;
, in that case the patch will be one-liner.
Akinobu, Andrew, I'd suggest to drop
workqueue-proper-error-unwinding-in-cpu-hotplug-error-path.patch
, I'll send the new patch. If nothing else, it is simpler.
Oleg.
next prev parent reply other threads:[~2008-07-22 10:20 UTC|newest]
Thread overview: 6+ messages / expand[flat|nested] mbox.gz Atom feed top
[not found] <200807220826.m6M8Q4I6018588@imap1.linux-foundation.org>
2008-07-22 8:45 ` Oleg Nesterov
2008-07-22 8:59 ` Akinobu Mita
2008-07-22 9:16 ` Oleg Nesterov
2008-07-22 9:55 ` Akinobu Mita
2008-07-22 10:23 ` Oleg Nesterov [this message]
2008-07-22 10:27 ` [PATCH] workqueues: do CPU_UP_CANCELED if CPU_UP_PREPARE fails Oleg Nesterov
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20080722102354.GA1068@tv-sign.ru \
--to=oleg@tv-sign.ru \
--cc=akinobu.mita@gmail.com \
--cc=akpm@linux-foundation.org \
--cc=linux-kernel@vger.kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®