From: Grant Grundler <grundler@parisc-linux.org>
To: Arjan van de Ven <arjan@infradead.org>
Cc: Grant Grundler <grundler@parisc-linux.org>,
linux-kernel@vger.kernel.org, linux-pci@vger.kernel.org
Subject: Re: [PATCH] pci: introduce users of ioremap_pcibar()
Date: Tue, 30 Sep 2008 23:24:50 -0600 [thread overview]
Message-ID: <20081001052450.GB7348@colo.lackof.org> (raw)
In-Reply-To: <20080929102325.0ca5c0c9@infradead.org>
On Mon, Sep 29, 2008 at 10:23:25AM -0700, Arjan van de Ven wrote:
> On Mon, 29 Sep 2008 11:10:49 -0600
> Grant Grundler <grundler@parisc-linux.org> wrote:
>
> > And I have to agree with willy/alan, pci_iomap() is already doing
> > this.
>
> pci_iomap() does "stuff" but it assumes you're using the iomap APIs
> across the driver. MANY don't.
pci_iomap() returns a "void __iomem *".
readl/writel take "void __iomem *" as an argument.
See build_mmio_read() in include/asm-x86/io.h
I think the assumption is the other way around: use of ioread/iowrite
assumes use of io_remap(). pci_iomap is the PCI wrapper around io_remap().
You just want a simpler wrapper (and I agree, it really could without
the extra arg).
But in any case, we can document pci_iomap() to be whatever you think
we should be exporting. pci_iomap() is not currently documented in
Documentation/. Or at least grep isn't seeing it.
> And pci_iomap() takes more parameters than most driver writers want or
> need. Most of the time it's "I want the whole bar"; even if my patch
> wraps around that, making the API simpler is still worth it imo
You are right about that.
Would calling the API "pci_iomap_bar()" to keep the naming consistent help
make it more acceptable?
(And adding documentation for both would be good too...I can do
that if the new API gets accepted.)
hth,
grant
next prev parent reply other threads:[~2008-10-01 5:25 UTC|newest]
Thread overview: 18+ messages / expand[flat|nested] mbox.gz Atom feed top
2008-09-26 23:36 [PATCH] pci: introduce an ioremap_pcibar(pdev, barnr) function Arjan van de Ven
2008-09-26 23:37 ` [PATCH] pci: introduce users of ioremap_pcibar() Arjan van de Ven
2008-09-29 7:26 ` Grant Grundler
2008-09-29 9:20 ` Alan Cox
2008-09-29 13:42 ` Arjan van de Ven
2008-09-29 17:10 ` Grant Grundler
2008-09-29 17:23 ` Arjan van de Ven
2008-10-01 5:24 ` Grant Grundler [this message]
2008-09-30 22:30 ` Arjan van de Ven
2008-10-01 10:33 ` Rolf Eike Beer
2008-10-01 12:42 ` Kyle McMartin
2008-10-01 12:57 ` Matthew Wilcox
2008-10-01 13:07 ` Kyle McMartin
2008-10-01 13:53 ` Arjan van de Ven
2008-09-27 2:56 ` [PATCH] pci: introduce an ioremap_pcibar(pdev, barnr) function Matthew Wilcox
2008-09-27 15:35 ` Arjan van de Ven
2008-09-29 18:08 [PATCH] pci: introduce users of ioremap_pcibar() Marin Mitov
2008-10-01 6:39 Marin Mitov
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20081001052450.GB7348@colo.lackof.org \
--to=grundler@parisc-linux.org \
--cc=arjan@infradead.org \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-pci@vger.kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®