mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Ingo Molnar <mingo@elte.hu>
To: Steven Rostedt <rostedt@goodmis.org>
Cc: linux-kernel@vger.kernel.org, Andrew Morton <akpm@linux-foundation.org>
Subject: Re: [PATCH 0/3] ftrace: separate ftrace from ftrace
Date: Mon, 20 Oct 2008 18:31:09 +0200	[thread overview]
Message-ID: <20081020163108.GA1035@elte.hu> (raw)
In-Reply-To: <20081006230610.024517480@goodmis.org>


* Steven Rostedt <rostedt@goodmis.org> wrote:

> There has been a lot of confusion between ftrace the infrastructure 
> and ftrace the function tracer within ftrace.  Developers have added 
> dependencies on HAVE_FTRACE when they did not need to. The HAVE_FTRACE 
> was the architecture supported the function tracer.
> 
> This patch series renames the ftrace function tracer to just that, 
> FUNCTION_TRACER.  And even renames the tracer shown to users from 
> 'ftrace' to 'function'.
> 
> Now, when referring to ftrace, it means the ftrace infrastructure, and 
> when referring to the function trace, it is now called the function 
> tracer.
> 
> The second patch cause a lot of files to be touched. Mostly Makefiles 
> and Kconfig files. As well as default configs.

applied the following bits to tip/tracing/ftrace:

 3ce83ae: ftrace: rename the ftrace tracer to function
 606576c: ftrace: rename FTRACE to FUNCTION_TRACER
 c2db805: ftrace: fix depends
 bd95b88: ftrace: release functions from hash
 c513867: ftrace: do not enclose logic in WARN_ON

thanks Steve! I left out the defconfig bits - out of sync symbol names 
there do not hurt, and those files are high-flux anyway and generally 
updated by the arch maintainers regularly.

	Ingo

      parent reply	other threads:[~2008-10-20 16:31 UTC|newest]

Thread overview: 5+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2008-10-06 23:06 Steven Rostedt
2008-10-06 23:06 ` [PATCH 1/3] ftrace: fix depends Steven Rostedt
2008-10-06 23:06 ` [PATCH 2/3] ftrace: rename FTRACE to FUNCTION_TRACER Steven Rostedt
2008-10-06 23:06 ` [PATCH 3/3] ftrace: rename the ftrace tracer to function Steven Rostedt
2008-10-20 16:31 ` Ingo Molnar [this message]

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20081020163108.GA1035@elte.hu \
    --to=mingo@elte.hu \
    --cc=akpm@linux-foundation.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=rostedt@goodmis.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

Powered by JetHome