mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Jean Delvare <khali@linux-fr.org>
To: Andrew Morton <akpm@linux-foundation.org>
Cc: LKML <linux-kernel@vger.kernel.org>,
	Hans de Goede <hdegoede@redhat.com>,
	Matthew Garrett <mjg@redhat.com>,
	Roland Dreier <rolandd@cisco.com>
Subject: Re: [PATCH] dmi: Let dmi_walk() users pass private data
Date: Tue, 3 Feb 2009 10:52:22 +0100	[thread overview]
Message-ID: <20090203105222.34f9f1b5@hyperion.delvare> (raw)
In-Reply-To: <20090203004210.235f162d.akpm@linux-foundation.org>

On Tue, 3 Feb 2009 00:42:10 -0800, Andrew Morton wrote:
> On Sun, 1 Feb 2009 22:46:59 +0100 Jean Delvare <khali@linux-fr.org> wrote:
> 
> > At the moment, dmi_walk() lacks flexibility, users can't pass data to
> > the callback function. Add a pointer for private data to make this
> > function more flexible.
> 
> That new argument is sometimes called "priv", other times called "data"
> and other times called "dummy".  It would be good to come up with a nice
> meaningful name and stick to it.
> 
> (The "dummy" thing probably makes sense, as long as people think to 
> rename it to the chosen identifier if they later actually use it for
> something).

Indeed, naming things "dummy" when they are required for prototype
reasons but otherwise unused is a rather common strategy.

As for "priv" vs. "data", I wanted to use "data" everywhere, but it
happens that we already have a local variable named "data" in function
dmi_table(). I didn't want to change it, to not make the patch bigger
and harder to read. If you think this is such a big issue, I could
either rename that local variable nevertheless, or use "priv"
everywhere (with the open question whether we should also use "priv"
instead of "data" in <linux/dmi.h> or not.) Let me know what you prefer.

Thanks,
-- 
Jean Delvare

  reply	other threads:[~2009-02-03  9:52 UTC|newest]

Thread overview: 5+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2009-02-01 21:46 Jean Delvare
2009-02-03  8:42 ` Andrew Morton
2009-02-03  9:52   ` Jean Delvare [this message]
2009-02-03 10:59     ` Andrew Morton
2009-02-03 15:11       ` Jean Delvare

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20090203105222.34f9f1b5@hyperion.delvare \
    --to=khali@linux-fr.org \
    --cc=akpm@linux-foundation.org \
    --cc=hdegoede@redhat.com \
    --cc=linux-kernel@vger.kernel.org \
    --cc=mjg@redhat.com \
    --cc=rolandd@cisco.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

Powered by JetHome