From: Heiko Carstens <heiko.carstens@de.ibm.com>
To: David Daney <ddaney@caviumnetworks.com>
Cc: Martin Schwidefsky <schwidefsky@de.ibm.com>,
Ralf Baechle <ralf@linux-mips.org>,
Linus Torvalds <torvalds@linux-foundation.org>,
Andrew Morton <akpm@linux-foundation.org>,
Linux Kernel Mailing List <linux-kernel@vger.kernel.org>
Subject: Re: Syscall wrappers breaks things.
Date: Sat, 21 Feb 2009 11:02:33 +0100 [thread overview]
Message-ID: <20090221110233.1baa9f5d@osiris.boeblingen.de.ibm.com> (raw)
In-Reply-To: <499EFB1A.7070801@caviumnetworks.com>
On Fri, 20 Feb 2009 10:48:58 -0800
David Daney <ddaney@caviumnetworks.com> wrote:
> In commit ee6a093222549ac0c72cfd296c69fa5e7d6daa34 the syscall wrappers
> infrastructure was introduced.
>
> A typical definition is something like this (from Ralf's patch):
>
> SYSCALL_DEFINE6(32_ipc, u32, call, long, first, long, second, long, third,
> unsigned long, ptr, unsigned long, fifth)
> {
> .
>
> This creates a symbol sys_32_ipc. The old name of the symbol is
> sys32_ipc (note the change in the number of '_').
>
> For the mips64 kernel the syscall table for o32 ABI executable contains:
> PTR sys32_ipc
> This is now linked to the sys32_ipc function in kernel/sys_ni.c which
> kindly returns ENOSYS.
Sure, the SYSCALL_DEFINE macros work only for system calls that follow
the sys_[whatever] naming convention. In this case the original system
call should be renamed. E.g. sys_mips_ipc.
> The long and short of the problem is that the is now a kernel wide
> mismatch in function names between the names created by SYSCALL_DEFINE*,
> the syscall tables and kernel/sys_ni.c.
Only if the macros are used in a wrong way.
> I am not sure what the best solution is, but something should probably
> be done to un-break things.
Fix the patch that converts mips to system call wrappers ;)
Ralf's patch isn't in Linus' repository nor is it in linux-next. Or at
least I couldn't find it. So it looks like you're talking about some
private git tree?
prev parent reply other threads:[~2009-02-21 10:02 UTC|newest]
Thread overview: 2+ messages / expand[flat|nested] mbox.gz Atom feed top
2009-02-20 18:48 David Daney
2009-02-21 10:02 ` Heiko Carstens [this message]
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20090221110233.1baa9f5d@osiris.boeblingen.de.ibm.com \
--to=heiko.carstens@de.ibm.com \
--cc=akpm@linux-foundation.org \
--cc=ddaney@caviumnetworks.com \
--cc=linux-kernel@vger.kernel.org \
--cc=ralf@linux-mips.org \
--cc=schwidefsky@de.ibm.com \
--cc=torvalds@linux-foundation.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®