From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1758117AbZBWUFS (ORCPT ); Mon, 23 Feb 2009 15:05:18 -0500 Received: (majordomo@vger.kernel.org) by vger.kernel.org id S1755627AbZBWUE7 (ORCPT ); Mon, 23 Feb 2009 15:04:59 -0500 Received: from smtp1.linux-foundation.org ([140.211.169.13]:51972 "EHLO smtp1.linux-foundation.org" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1755257AbZBWUE6 (ORCPT ); Mon, 23 Feb 2009 15:04:58 -0500 Date: Mon, 23 Feb 2009 12:04:01 -0800 From: Andrew Morton To: Ingo Molnar Cc: paulmck@linux.vnet.ibm.com, nickpiggin@yahoo.com.au, vegard.nossum@gmail.com, stable@kernel.org, npiggin@suse.de, penberg@cs.helsinki.fi, linux-kernel@vger.kernel.org Subject: Re: [PATCH] mm: fix lazy vmap purging (use-after-free error) Message-Id: <20090223120401.b1354133.akpm@linux-foundation.org> In-Reply-To: <20090223193351.GA11921@elte.hu> References: <20090220140157.GA12799@elte.hu> <20090222030030.GD6860@linux.vnet.ibm.com> <20090223051709.GA5990@linux.vnet.ibm.com> <200902240029.37815.nickpiggin@yahoo.com.au> <20090223161726.GD6751@linux.vnet.ibm.com> <20090223111009.d48ff81d.akpm@linux-foundation.org> <20090223193351.GA11921@elte.hu> X-Mailer: Sylpheed version 2.2.4 (GTK+ 2.8.20; i486-pc-linux-gnu) Mime-Version: 1.0 Content-Type: text/plain; charset=US-ASCII Content-Transfer-Encoding: 7bit Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org On Mon, 23 Feb 2009 20:33:51 +0100 Ingo Molnar wrote: > > > > Nice work all (btw. if this patch goes in rather than using system_state, > > > > then please make the variable __read_mostly). > > > > > > Hmmm... I misread this and made system_state be __read_mostly. Let > > > me know if this is bad, easy to fix if needed. > > > > Please don't use system_state. The whole thing is just bad > > design. It's a global variable, breaks encapsulation, creates > > interactions etc. CS-101 stuff. > > ok, i've removed the patch Thanks. > - Paul, would you mind to re-send > your original flag solution, with it marked __read_mostly and > with the extern declarations put into a suitable header file? It would still make sense to mark system_state __read_mostly. (That's assuming that __read_mostly makes sense. I still wanna rename it to __pack_all_write_often_variables_into_the_same_cacheline and see what happens then)