From: Christoph Hellwig <hch@infradead.org>
To: Steven Rostedt <rostedt@goodmis.org>
Cc: linux-kernel@vger.kernel.org, Ingo Molnar <mingo@elte.hu>,
Andrew Morton <akpm@linux-foundation.org>,
Thomas Gleixner <tglx@linutronix.de>,
Peter Zijlstra <peterz@infradead.org>,
Frederic Weisbecker <fweisbec@gmail.com>,
Theodore Tso <tytso@mit.edu>,
Arnaldo Carvalho de Melo <acme@redhat.com>,
"H. Peter Anvin" <hpa@zytor.com>,
Mathieu Desnoyers <compudj@krystal.dyndns.org>,
Lai Jiangshan <laijs@cn.fujitsu.com>,
"Martin J. Bligh" <mbligh@mbligh.org>,
"Frank Ch. Eigler" <fche@redhat.com>,
KOSAKI Motohiro <kosaki.motohiro@jp.fujitsu.com>,
Larry Woodman <lwoodman@redhat.com>,
Jason Baron <jbaron@redhat.com>, Tom Zanussi <tzanussi@gmail.com>,
Masami Hiramatsu <mhiramat@redhat.com>,
Christoph Hellwig <hch@infradead.org>,
Jiaying Zhang <jiayingz@google.com>,
Steven Rostedt <srostedt@redhat.com>
Subject: Re: [PATCH 4/7] tracing: new format for specialized trace points
Date: Tue, 17 Mar 2009 04:08:01 -0400 [thread overview]
Message-ID: <20090317080801.GB9960@infradead.org> (raw)
In-Reply-To: <20090310045811.279394388@goodmis.org>
On Tue, Mar 10, 2009 at 12:57:14AM -0400, Steven Rostedt wrote:
> Here's the example. The only updated macro in this patch is the
> sched_switch trace point.
Note that we shouldn't keep two variants around long-term, that's
just going to cause confusion.
> The old method looked like this:
>
> TRACE_EVENT_FORMAT(sched_switch,
> TP_PROTO(struct rq *rq, struct task_struct *prev,
> struct task_struct *next),
> TP_ARGS(rq, prev, next),
> TP_FMT("task %s:%d ==> %s:%d",
> prev->comm, prev->pid, next->comm, next->pid),
> TRACE_STRUCT(
> TRACE_FIELD(pid_t, prev_pid, prev->pid)
> TRACE_FIELD(int, prev_prio, prev->prio)
> TRACE_FIELD_SPECIAL(char next_comm[TASK_COMM_LEN],
> next_comm,
> TP_CMD(memcpy(TRACE_ENTRY->next_comm,
> next->comm,
> TASK_COMM_LEN)))
> TRACE_FIELD(pid_t, next_pid, next->pid)
> TRACE_FIELD(int, next_prio, next->prio)
> ),
> TP_RAW_FMT("prev %d:%d ==> next %s:%d:%d")
> );
>
> The above method is hard to read and requires two format fields.
>
> The new method:
>
> /*
> * Tracepoint for task switches, performed by the scheduler:
> *
> * (NOTE: the 'rq' argument is not used by generic trace events,
> * but used by the latency tracer plugin. )
> */
> TRACE_EVENT(sched_switch,
>
> TP_PROTO(struct rq *rq, struct task_struct *prev,
> struct task_struct *next),
>
> TP_ARGS(rq, prev, next),
>
> TP_STRUCT__entry(
> __array( char, prev_comm, TASK_COMM_LEN )
> __field( pid_t, prev_pid )
> __field( int, prev_prio )
> __array( char, next_comm, TASK_COMM_LEN )
> __field( pid_t, next_pid )
> __field( int, next_prio )
> ),
>
> TP_printk("task %s:%d [%d] ==> %s:%d [%d]",
> __entry->prev_comm, __entry->prev_pid, __entry->prev_prio,
> __entry->next_comm, __entry->next_pid, __entry->next_prio),
>
> TP_fast_assign(
> memcpy(__entry->next_comm, next->comm, TASK_COMM_LEN);
> __entry->prev_pid = prev->pid;
> __entry->prev_prio = prev->prio;
> memcpy(__entry->prev_comm, prev->comm, TASK_COMM_LEN);
> __entry->next_pid = next->pid;
> __entry->next_prio = next->prio;
> )
> );
While the idea behing it seems like an improvement to me, the
implementation feel actually worse than the old one too me. I would
expect this to look more like:
struct trace_sched_switch {
char prev_comm[TASK_COMM_LEN],
pid_t prev_pid,
int prev_prio,
char next_comm[TASK_COMM_LEN],
pid_t next_pid,
int next_prio,
}
static void trace_sched_assign(struct trace_sched_switch *dst, struct rq *rq,
struct task_struct *prev, struct task_struct *next)
{
memcpy(dst->next_comm, next->comm, TASK_COMM_LEN);
dst->prev_pid = prev->pid;
dst->prev_prio = prev->prio;
memcpy(dst->prev_comm, prev->comm, TASK_COMM_LEN);
dst->next_pid = next->pid;
dst->next_prio = next->prio;
};
TRACE_EVENT(sched_switch,
trace_proto(struct rq *rq, struct task_struct *prev,
struct task_struct *next),
trace_args(rq, prev, next),
trace_struct(struct trace_sched_switch),
trace_assign(trace_sched_assign);
trace_pretty_print("task %s:%d [%d] ==> %s:%d [%d]",
__entry->prev_comm, __entry->prev_pid, __entry->prev_prio,
__entry->next_comm, __entry->next_pid, __entry->next_prio),
);
next prev parent reply other threads:[~2009-03-17 8:08 UTC|newest]
Thread overview: 25+ messages / expand[flat|nested] mbox.gz Atom feed top
2009-03-10 4:57 [PATCH 0/7] [GIT PULL] enhancements for tracing in tip Steven Rostedt
2009-03-10 4:57 ` [PATCH 1/7] tracing: typecast sizeof and offsetof to unsigned int Steven Rostedt
2009-03-10 5:20 ` Andrew Morton
2009-03-10 13:39 ` Steven Rostedt
2009-03-10 4:57 ` [PATCH 2/7] tracing: replace TP<var> with TP_<var> Steven Rostedt
2009-03-17 7:58 ` Christoph Hellwig
2009-03-17 15:30 ` Steven Rostedt
2009-03-10 4:57 ` [PATCH 3/7] tracing: use generic __stringify Steven Rostedt
2009-03-10 10:56 ` Frederic Weisbecker
2009-03-10 11:18 ` KOSAKI Motohiro
2009-03-10 11:21 ` Peter Zijlstra
2009-03-10 15:48 ` Frédéric Weisbecker
2009-03-10 4:57 ` [PATCH 4/7] tracing: new format for specialized trace points Steven Rostedt
2009-03-10 5:50 ` KOSAKI Motohiro
2009-03-10 8:54 ` Ingo Molnar
2009-03-10 13:45 ` Steven Rostedt
2009-03-10 9:54 ` KOSAKI Motohiro
2009-03-10 13:55 ` Steven Rostedt
2009-03-17 8:08 ` Christoph Hellwig [this message]
2009-03-17 15:41 ` Steven Rostedt
2009-03-10 4:57 ` [PATCH 5/7] tracing: convert the sched trace points to the TRACE_EVENT macros Steven Rostedt
2009-03-10 4:57 ` [PATCH 6/7] tracing: convert irq trace points to new macros Steven Rostedt
2009-03-10 4:57 ` [PATCH 7/7] tracing: remove obsolete TRACE_EVENT_FORMAT macro Steven Rostedt
2009-03-17 8:08 ` Christoph Hellwig
2009-03-10 8:59 ` [PATCH 0/7] [GIT PULL] enhancements for tracing in tip Ingo Molnar
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20090317080801.GB9960@infradead.org \
--to=hch@infradead.org \
--cc=acme@redhat.com \
--cc=akpm@linux-foundation.org \
--cc=compudj@krystal.dyndns.org \
--cc=fche@redhat.com \
--cc=fweisbec@gmail.com \
--cc=hpa@zytor.com \
--cc=jbaron@redhat.com \
--cc=jiayingz@google.com \
--cc=kosaki.motohiro@jp.fujitsu.com \
--cc=laijs@cn.fujitsu.com \
--cc=linux-kernel@vger.kernel.org \
--cc=lwoodman@redhat.com \
--cc=mbligh@mbligh.org \
--cc=mhiramat@redhat.com \
--cc=mingo@elte.hu \
--cc=peterz@infradead.org \
--cc=rostedt@goodmis.org \
--cc=srostedt@redhat.com \
--cc=tglx@linutronix.de \
--cc=tytso@mit.edu \
--cc=tzanussi@gmail.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®