From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1763153AbZCQK04 (ORCPT ); Tue, 17 Mar 2009 06:26:56 -0400 Received: (majordomo@vger.kernel.org) by vger.kernel.org id S1754141AbZCQK0r (ORCPT ); Tue, 17 Mar 2009 06:26:47 -0400 Received: from mx2.mail.elte.hu ([157.181.151.9]:38963 "EHLO mx2.mail.elte.hu" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1753696AbZCQK0q (ORCPT ); Tue, 17 Mar 2009 06:26:46 -0400 Date: Tue, 17 Mar 2009 11:26:29 +0100 From: Ingo Molnar To: Jaswinder Singh Rajput Cc: Thomas Gleixner , x86 maintainers , LKML Subject: Re: [git-pull -tip] x86: cleanup 20090317 Message-ID: <20090317102629.GH6477@elte.hu> References: <1237229111.2827.2.camel@ht.satnam> <1237267595.2480.9.camel@ht.satnam> <1237279833.3464.4.camel@ht.satnam> MIME-Version: 1.0 Content-Type: text/plain; charset=us-ascii Content-Disposition: inline In-Reply-To: <1237279833.3464.4.camel@ht.satnam> User-Agent: Mutt/1.5.18 (2008-05-17) X-ELTE-VirusStatus: clean X-ELTE-SpamScore: -1.5 X-ELTE-SpamLevel: X-ELTE-SpamCheck: no X-ELTE-SpamVersion: ELTE 2.0 X-ELTE-SpamCheck-Details: score=-1.5 required=5.9 tests=BAYES_00 autolearn=no SpamAssassin version=3.2.3 -1.5 BAYES_00 BODY: Bayesian spam probability is 0 to 1% [score: 0.0000] Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org * Jaswinder Singh Rajput wrote: > On Tue, 2009-03-17 at 09:38 +0100, Thomas Gleixner wrote: > > On Tue, 17 Mar 2009, Jaswinder Singh Rajput wrote: > > > On Mon, 2009-03-16 at 23:33 +0100, Thomas Gleixner wrote: > > > > On Tue, 17 Mar 2009, Jaswinder Singh Rajput wrote: > > > > > > > > > -static struct clock_event_device pit_clockevent = { > > > > > +static struct clock_event_device pit_dev = { > > > > > > > > Why do we need to change the name of the variable ? Just for fun or > > > > is pit_dev more self explaining than pit_clockevent ? > > > > > > pit already means it is a clock event, but with this change: > > > > > > 1. we save 8 characters per declaration > > > 2. It solves various 80 characters problem > > > > There is not a single 80 character problem in that file. > > Here are 80 character problems: > > 1. pit_clockevent.mult = div_sc(CLOCK_TICK_RATE, NSEC_PER_SEC, > pit_clockevent.shift); > 2. pit_clockevent.max_delta_ns = > clockevent_delta2ns(0x7FFF, &pit_clockevent); > 3. pit_clockevent.min_delta_ns = > clockevent_delta2ns(0xF, &pit_clockevent); > > 4. clocksource_pit.mult = clocksource_hz2mult(CLOCK_TICK_RATE, > clocksource_pit.shift); We could rename "pit_clockevent" to "pit_ce" perhaps - if Thomas agrees. pit_dev sounds weird. pure (non-code-changing) cleanups should be kept separate from code changing cleanups. Ingo