From: Ingo Molnar <mingo@elte.hu>
To: David Rientjes <rientjes@google.com>
Cc: Andrew Morton <akpm@linux-foundation.org>, linux-kernel@vger.kernel.org
Subject: Re: [patch] vmscan: print shrink_slab symbol name on negative shrinker objects
Date: Fri, 20 Mar 2009 09:27:12 +0100 [thread overview]
Message-ID: <20090320082712.GB31137@elte.hu> (raw)
In-Reply-To: <alpine.DEB.2.00.0903191609040.2457@chino.kir.corp.google.com>
* David Rientjes <rientjes@google.com> wrote:
> When a shrinker has a negative number of objects to delete, the symbol
> name of the shrinker should be printed, not shrink_slab.
>
> Signed-off-by: David Rientjes <rientjes@google.com>
> ---
> mm/vmscan.c | 9 +++++++--
> 1 files changed, 7 insertions(+), 2 deletions(-)
>
> diff --git a/mm/vmscan.c b/mm/vmscan.c
> --- a/mm/vmscan.c
> +++ b/mm/vmscan.c
> @@ -40,6 +40,7 @@
> #include <linux/memcontrol.h>
> #include <linux/delayacct.h>
> #include <linux/sysctl.h>
> +#include <linux/kallsyms.h>
>
> #include <asm/tlbflush.h>
> #include <asm/div64.h>
> @@ -214,8 +215,12 @@ unsigned long shrink_slab(unsigned long scanned, gfp_t gfp_mask,
> do_div(delta, lru_pages + 1);
> shrinker->nr += delta;
> if (shrinker->nr < 0) {
> - printk(KERN_ERR "%s: nr=%ld\n",
> - __func__, shrinker->nr);
> + char symname[KSYM_NAME_LEN];
> +
> + if (lookup_symbol_name((unsigned long)shrinker->shrink,
> + symname) > 0)
> + printk(KERN_ERR "shrink_slab: %s nr=%ld\n",
> + symname, shrinker->nr);
> shrinker->nr = max_pass;
Please dont open-code lookup_symbol_name() for function pointers -
we have %pF for such purposes.
Btw., probably all existing print_symbol() uses in mm/*.c should be
converted to %pF:
mm/memory.c: print_symbol(KERN_ALERT "vma->vm_ops->fault: %s\n",
mm/memory.c: print_symbol(KERN_ALERT "vma->vm_file->f_op->mmap: %s\n",
mm/slab.c: print_symbol("(%s)",
mm/slub.c: len += sprint_symbol(buf + len, (unsigned long)l->addr);
mm/slub.c: int n = sprint_symbol(buf, (unsigned long)s->ctor);
mm/vmalloc.c: sprint_symbol(buff, (unsigned long)v->caller);
[ Except the second slub.c one which should be %pS ]
Ingo
prev parent reply other threads:[~2009-03-20 8:28 UTC|newest]
Thread overview: 4+ messages / expand[flat|nested] mbox.gz Atom feed top
2009-03-19 23:09 David Rientjes
2009-03-19 23:33 ` Andrew Morton
2009-03-20 10:15 ` David Rientjes
2009-03-20 8:27 ` Ingo Molnar [this message]
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20090320082712.GB31137@elte.hu \
--to=mingo@elte.hu \
--cc=akpm@linux-foundation.org \
--cc=linux-kernel@vger.kernel.org \
--cc=rientjes@google.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®