mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Stephen Neuendorffer <stephen.neuendorffer@xilinx.com>
To: <microblaze-uclinux@itee.uq.edu.au>,
	"John Williams" <john.williams@petalogix.com>
Cc: <linux-kernel@vger.kernel.org>, "Michal Simek" <monstr@monstr.eu>
Subject: RE: [microblaze-uclinux] [PATCH 11/11] microblaze: Kconfig: Enable drivers for Microblaze
Date: Fri, 17 Apr 2009 10:21:46 -0700	[thread overview]
Message-ID: <20090417172216.C55431620052@mail15-sin.bigfish.com> (raw)
In-Reply-To: <fa686aa40904162352g34ea9492ne4db432fd388941a@mail.gmail.com>



> -----Original Message-----
> From: owner-microblaze-uclinux@itee.uq.edu.au [mailto:owner-microblaze-uclinux@itee.uq.edu.au] On
> Behalf Of Grant Likely
> Sent: Thursday, April 16, 2009 11:52 PM
> To: John Williams
> Cc: microblaze-uclinux@itee.uq.edu.au; linux-kernel@vger.kernel.org; Michal Simek
> Subject: Re: [microblaze-uclinux] [PATCH 11/11] microblaze: Kconfig: Enable drivers for Microblaze
> 
> On Thu, Apr 16, 2009 at 11:01 PM, John Williams
> <john.williams@petalogix.com> wrote:
> > On Thu, Apr 16, 2009 at 7:56 PM,  <monstr@monstr.eu> wrote:
> >> From: Michal Simek <monstr@monstr.eu>
> >>
> >> Signed-off-by: Michal Simek <monstr@monstr.eu>
> >
> > ACK from a MicroBlaze perspective, but some other comments below:
> 
> Acked-by: Grant Likely <grant.likely@secretlab.ca>
> 
> But I'm not sure who should pick this up.
> 
> >
> > A note more for the Xilinx PPC folks (ie Grant Likely):
> >
> > Shouldn't some of these Kconfig depends for PPC be unified?  We have:
> >
> >>  config XILINX_SYSACE
> >>        tristate "Xilinx SystemACE support"
> >> -       depends on 4xx
> >> +       depends on 4xx || MICROBLAZE
> >
> >>  config XILINX_HWICAP
> >>        tristate "Xilinx HWICAP Support"
> >> -       depends on XILINX_VIRTEX
> >> +       depends on XILINX_VIRTEX || MICROBLAZE
> >
> >
> >>  config GPIO_XILINX
> >>        bool "Xilinx GPIO support"
> >> -       depends on PPC_OF
> >> +       depends on PPC_OF || MICROBLAZE
> >>        help
> >>          Say yes here to support the Xilinx FPGA GPIO device
> >
> > Are these all really different options?  PPC_OF?  XILINX_VIRTEX?  4xx?
> 
> xsysace should just depend on either PPC or OF.  It is applicable to
> more than just virtex/spartan systems (I know of at least one
> non-virtex 440 board with a systemace, hence the 4xx usage), and it is
> conceivable that it would be used on other architectures.
> 
> XILINX_VIRTEX makes some sense for hwicap
> 
> PPC_OF doesn't have any real meaning anymore.  PPC would be better.

I'd like to see a single configuration option that makes all of these drivers available.  That way, any processor system (x86, soft arm core, etc.) could turn those on.. The only thing these drivers *REALLY* depend on is OF...  I've circulated patches to do this several times, although they're probably hopelessly out of date at this point.

Steve

This email and any attachments are intended for the sole use of the named recipient(s) and contain(s) confidential information that may be proprietary, privileged or copyrighted under applicable law. If you are not the intended recipient, do not read, copy, or forward this email message or any attachments. Delete this email message and any attachments immediately.



  reply	other threads:[~2009-04-17 17:22 UTC|newest]

Thread overview: 32+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2009-04-16  9:56 Microblaze fixes for revision monstr
2009-04-16  9:56 ` [PATCH 01/11] microblaze: Remove unneded per cpu SYSCALL_SAVE variable monstr
2009-04-16  9:56   ` [PATCH 02/11] microblaze: Remove while(1) loop from show_regs function monstr
2009-04-16  9:56     ` [PATCH 03/11] microblaze: Remove uncache shadow condition monstr
2009-04-16  9:56       ` [PATCH 04/11] microblaze: Rename kernel_mode to pt_mode in pt_regs monstr
2009-04-16  9:56         ` [PATCH 05/11] microblaze: Move task_pt_regs up monstr
2009-04-16  9:56           ` [PATCH 06/11] microblaze: Remove sparse error in traps.c monstr
2009-04-16  9:56             ` [PATCH 07/11] microblaze: Add missing declaration for die and _exception func monstr
2009-04-16  9:56               ` [PATCH 08/11] microblaze: Add missing preadv and pwritev syscalls monstr
2009-04-16  9:56                 ` [PATCH 09/11] microblaze: Move start_thread to process.c monstr
2009-04-16  9:56                   ` [PATCH 10/11] microblaze: Remove redundant variable monstr
2009-04-16  9:56                     ` [PATCH 11/11] microblaze: Kconfig: Enable drivers for Microblaze monstr
2009-04-17  5:01                       ` [microblaze-uclinux] " John Williams
2009-04-17  6:52                         ` Grant Likely
2009-04-17 17:21                           ` Stephen Neuendorffer [this message]
2009-04-17 17:06                       ` Stephen Neuendorffer
2009-04-18  5:49                         ` Grant Likely
2009-04-19  9:25                           ` who know's what is "TestFloat cases" and how to test this feature on the Freescale MPC8536DS board derekzheng
2009-04-19 16:40                             ` Kumar Gala
2009-04-20  7:41                             ` who know's what is "TestFloat cases" and how to test this feature onthe " Liu Yu-B13201
     [not found]                           ` <495563870904181941o5a66126dgb59d8cad2b7a66f2@mail.gmail.com>
2009-04-19 23:03                             ` [microblaze-uclinux] [PATCH 11/11] microblaze: Kconfig: Enable drivers for Microblaze John Williams
     [not found]                               ` <977C41F842E66D4CB2E41332313B6150069D3D27@XSJ-EXCHVS1.xlnx.xilinx.com>
2009-04-20 14:36                                 ` John Linn
2009-04-20 14:48                                   ` Grant Likely
2009-04-21  2:24                                     ` John Williams
2009-04-17  4:57                     ` [microblaze-uclinux] [PATCH 10/11] microblaze: Remove redundant variable John Williams
2009-04-17  4:57                   ` [microblaze-uclinux] [PATCH 09/11] microblaze: Move start_thread to process.c John Williams
2009-04-17  4:56                 ` [microblaze-uclinux] [PATCH 08/11] microblaze: Add missing preadv and pwritev syscalls John Williams
2009-04-17  4:55               ` [microblaze-uclinux] [PATCH 07/11] microblaze: Add missing declaration for die and _exception func John Williams
2009-04-17  4:55             ` [microblaze-uclinux] [PATCH 06/11] microblaze: Remove sparse error in traps.c John Williams
2009-04-17  2:25     ` [microblaze-uclinux] [PATCH 02/11] microblaze: Remove while(1) loop from show_regs function John Williams
2009-04-20 20:31 ` Microblaze fixes for revision Andrew Morton
2009-04-21  6:30   ` Michal Simek

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20090417172216.C55431620052@mail15-sin.bigfish.com \
    --to=stephen.neuendorffer@xilinx.com \
    --cc=john.williams@petalogix.com \
    --cc=linux-kernel@vger.kernel.org \
    --cc=microblaze-uclinux@itee.uq.edu.au \
    --cc=monstr@monstr.eu \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

Powered by JetHome