From: Jeff Garzik <jeff@garzik.org>
To: LKML <linux-kernel@vger.kernel.org>
Cc: linux-ide@vger.kernel.org, linux-scsi@vger.kernel.org,
axboe@kernel.dk, hch@lst.de
Subject: [PATCH 0/2] Putting bio_list into struct request?
Date: Sun, 19 Apr 2009 12:12:34 -0400 [thread overview]
Message-ID: <20090419161234.GA12105@havoc.gtf.org> (raw)
Now that we have bio_list in include/linux/bio.h, I wanted to see what
would happen when I replaced rq->{bio,biotail} with rq->bio_list.
Personally, I think the result is more readable, and indicates to all
users that rq->bio is really a list (even if a list with one entry).
Also, it highlights some bio users in downstream drivers, and hopefully
serves to increase the amount of bio-related review in those drivers.
The first patch is a straightforward replacement, with no code or
behavior changes (any such is a bug in the patch...):
- null/not-null tests become bio_list_empty()
- rq->bio becomes rq->bio_list.head
- rq->biotail becomes rq->bio_list.tail
- in a few cases, bio_list_xxx functions are called
as appropriate
The second patch are fixes to what I believe are minor bugs in the
bio-list-aware block core. Even if patch #1 is not accepted, these
fixes are likely needed regardless. Typically the bugs are of the type
"we forgot to update rq->biotail".
But maybe some of those are on purpose. Who knows, give it a
look... it is quite muddled which block core functions want 'bio'
as a list, or just a singleton 'bio'. Maybe I just got confused.
If nothing else, it helps to give this area of block another look, IMO.
Jeff
next reply other threads:[~2009-04-19 16:12 UTC|newest]
Thread overview: 4+ messages / expand[flat|nested] mbox.gz Atom feed top
2009-04-19 16:12 Jeff Garzik [this message]
2009-04-19 16:13 ` [PATCH 1/2] Update struct request to use bio_list Jeff Garzik
2009-04-19 16:14 ` [PATCH 2/2] Fix bugs found during bio_list update Jeff Garzik
2009-04-19 17:44 ` [PATCH 0/2] Putting bio_list into struct request? Jens Axboe
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20090419161234.GA12105@havoc.gtf.org \
--to=jeff@garzik.org \
--cc=axboe@kernel.dk \
--cc=hch@lst.de \
--cc=linux-ide@vger.kernel.org \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-scsi@vger.kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®