From: Borislav Petkov <petkovbb@googlemail.com>
To: Bartlomiej Zolnierkiewicz <bzolnier@gmail.com>
Cc: Borislav Petkov <petkovbb@googlemail.com>,
linux-ide@vger.kernel.org, linux-kernel@vger.kernel.org
Subject: Re: [PATCH 03/14] ide-atapi: switch to rq->resid_len
Date: Mon, 11 May 2009 09:23:49 +0200 [thread overview]
Message-ID: <20090511072349.GA21045@liondog.tnic> (raw)
In-Reply-To: <200905102332.33022.bzolnier@gmail.com>
On Sun, May 10, 2009 at 11:32:32PM +0200, Bartlomiej Zolnierkiewicz wrote:
> On Saturday 09 May 2009 09:45:23 Borislav Petkov wrote:
> > Now that we have rq->resid_len, use it to account partial completion
> > amount during the lifetime of an rq, decrementing it on each successful
> > transfer. As a result, get rid of now unused pc->xferred.
> >
> > While at it, remove noisy debug call in ide_prep_sense.
> >
> > Signed-off-by: Borislav Petkov <petkovbb@gmail.com>
> > ---
> > drivers/ide/ide-atapi.c | 17 ++++++++---------
> > drivers/ide/ide-tape.c | 11 ++++-------
> > include/linux/ide.h | 2 --
> > 3 files changed, 12 insertions(+), 18 deletions(-)
>
> WARNING: line over 80 characters
> #118: FILE: drivers/ide/ide-tape.c:370:
> + int blocks = (blk_rq_bytes(rq) - rq->resid_len) / tape->blk_size;
No worries, I haven't forgotten the checkpatch thing but the line is
81 chars and I just didn't want to split it because of _one_ char. The
benefit of readability of having it on one line should be more important
than one stupid static rule. I think we should relax it if enforcing it
worsens readability...
int blocks = (blk_rq_bytes(rq) - rq->resid_len) /
tape->blk_size;
Now this looks awful, IMHO. I'd much rather not listen to checkpatch
here.
--
Regards/Gruss,
Boris.
next prev parent reply other threads:[~2009-05-11 7:24 UTC|newest]
Thread overview: 30+ messages / expand[flat|nested] mbox.gz Atom feed top
2009-05-09 7:45 [RFC PATCH 0/12] ide-atapi remove pc->buf Borislav Petkov
2009-05-09 7:45 ` [PATCH 01/14] ide-tape: fix potential fs requests bug Borislav Petkov
2009-05-09 8:02 ` Sam Ravnborg
2009-05-09 8:50 ` Borislav Petkov
2009-05-09 10:25 ` Sam Ravnborg
2009-05-09 12:09 ` Borislav Petkov
2009-05-09 7:45 ` [PATCH 02/14] ide-atapi: switch to blk_rq_bytes() on do_request() path Borislav Petkov
2009-05-10 21:32 ` Bartlomiej Zolnierkiewicz
2009-05-09 7:45 ` [PATCH 03/14] ide-atapi: switch to rq->resid_len Borislav Petkov
2009-05-10 21:32 ` Bartlomiej Zolnierkiewicz
2009-05-11 7:23 ` Borislav Petkov [this message]
2009-05-11 11:22 ` Bartlomiej Zolnierkiewicz
2009-05-12 14:38 ` Sergei Shtylyov
2009-05-09 7:45 ` [PATCH 04/14] ide-atapi: add a len-parameter to ide_queue_pc_tail Borislav Petkov
2009-05-09 7:45 ` [PATCH 05/14] ide-atapi: add a buffer-arg " Borislav Petkov
2009-05-10 21:32 ` Bartlomiej Zolnierkiewicz
2009-05-09 7:45 ` [PATCH 06/14] ide-floppy/ide_floppy_get_flexible_disk_page: use local buffer Borislav Petkov
2009-05-09 7:45 ` [PATCH 07/14] ide-floppy/ide_floppy_get_sfrp_bit: " Borislav Petkov
2009-05-09 7:45 ` [PATCH 08/14] ide-floppy/ide_floppy_format_unit: " Borislav Petkov
2009-05-09 7:45 ` [PATCH 09/14] ide-atapi: use local sense buffer Borislav Petkov
2009-05-10 21:32 ` Bartlomiej Zolnierkiewicz
2009-05-12 7:17 ` Borislav Petkov
2009-05-09 7:45 ` [PATCH 10/14] ide-tape: fix READ POSITION cmd handling Borislav Petkov
2009-05-09 7:45 ` [PATCH 11/14] ide-tape/ide_tape_get_bsize_from_bdesc: use local buffer Borislav Petkov
2009-05-09 7:45 ` [PATCH 12/14] ide-atapi: remove pc->buf Borislav Petkov
2009-05-09 7:45 ` [PATCH 13/14] ide-cd: use whole request_sense buffer in EH Borislav Petkov
2009-05-09 7:45 ` [PATCH 14/14] ide: unify interrupt reason checking Borislav Petkov
2009-05-10 21:39 ` Bartlomiej Zolnierkiewicz
2009-05-10 21:32 ` [RFC PATCH 0/12] ide-atapi remove pc->buf Bartlomiej Zolnierkiewicz
2009-05-10 23:30 ` Tejun Heo
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20090511072349.GA21045@liondog.tnic \
--to=petkovbb@googlemail.com \
--cc=bp@kernel.org \
--cc=bzolnier@gmail.com \
--cc=linux-ide@vger.kernel.org \
--cc=linux-kernel@vger.kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®