From: Sergey Senozhatsky <sergey.senozhatsky@mail.by>
To: "Eric W. Biederman" <ebiederm@xmission.com>
Cc: Sergey Senozhatsky <sergey.senozhatsky@mail.by>,
Greg KH <gregkh@suse.de>, Kay Sievers <kay.sievers@vrfy.org>,
linux-kernel@vger.kernel.org
Subject: Re: [PATCH] kobject_set_name_vargs memory leak
Date: Sat, 27 Jun 2009 12:33:59 +0300 [thread overview]
Message-ID: <20090627093359.GA3342@localdomain.by> (raw)
In-Reply-To: <m18wjeqven.fsf@fess.ebiederm.org>
On (06/26/09 19:10), Eric W. Biederman wrote:
> Date: Fri, 26 Jun 2009 19:10:08 -0700
> From: "Eric W. Biederman" <ebiederm@xmission.com>
> To: Sergey Senozhatsky <sergey.senozhatsky@mail.by>
> Cc: Greg KH <gregkh@suse.de>, Kay Sievers <kay.sievers@vrfy.org>,
> linux-kernel@vger.kernel.org
> Subject: Re: [PATCH] kobject_set_name_vargs memory leak
> User-Agent: Gnus/5.11 (Gnus v5.11) Emacs/22.2 (gnu/linux)
>
> Sergey Senozhatsky <sergey.senozhatsky@mail.by> writes:
>
> > On (06/26/09 07:49), Greg KH wrote:
> >> We've been through this before (search lkml archives). If kvasprintf
> >> fails, then we don't want to free old_name, as the caller might want to
> >> do something with it.
> >>
> >> Or something along those lines, I can't remember the exact reasoning
> >> this early in the morning.
> >>
> >> Kay, do you remember?
> >>
> > I found.
> > http://lkml.org/lkml/2009/5/11/11
> >
> >>kobject with name set before should not come into this function,
> >>kobject_rename should be used instead.
> >
> > It's just would be safer to kfree or restore I guess.
>
> Yes. There does seem to be a good point in there that the code should be:
> BUG_ON(kobj->name);
>
> And otherwise simply not handle old_name at all.
>
I run with:
if (kobj->name) {
printk(KERN_ERR "name:%s fmt:%s\n", kobj->name, fmt);
dump_stack();
}
I seems ok not to handle old_name.
>Dave Young
>I rethought about this problem, does such issue exist really? I means
>that kobject->name != NULL scenario.
>
>there's following comments of this function:
>
> * This sets the name of the kobject. If you have already added the
> * kobject to the system, you must call kobject_rename() in order to
> * change the name of the kobject
Greg, Kay, Eric, what do you think?
diff --git a/lib/kobject.c b/lib/kobject.c
index b512b74..fd1983a 100644
--- a/lib/kobject.c
+++ b/lib/kobject.c
@@ -215,7 +215,6 @@ static int kobject_add_internal(struct kobject *kobj)
int kobject_set_name_vargs(struct kobject *kobj, const char *fmt,
va_list vargs)
{
- const char *old_name = kobj->name;
char *s;
if (kobj->name && !fmt)
> Eric
>
Sergey
next prev parent reply other threads:[~2009-06-27 9:32 UTC|newest]
Thread overview: 15+ messages / expand[flat|nested] mbox.gz Atom feed top
2009-06-26 14:36 Sergey Senozhatsky
2009-06-26 14:49 ` Greg KH
2009-06-26 22:29 ` Sergey Senozhatsky
2009-06-26 23:00 ` Eric W. Biederman
2009-06-26 23:14 ` Sergey Senozhatsky
2009-06-26 23:23 ` Sergey Senozhatsky
2009-06-27 2:10 ` Eric W. Biederman
2009-06-27 9:33 ` Sergey Senozhatsky [this message]
2009-06-27 9:39 ` Sergey Senozhatsky
2009-06-27 23:56 ` Kay Sievers
2009-06-28 12:07 ` Eric W. Biederman
2009-06-28 13:02 ` Kay Sievers
2009-06-28 13:13 ` Eric W. Biederman
2009-06-28 13:40 ` Sergey Senozhatsky
2009-06-29 9:53 ` Dave Young
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20090627093359.GA3342@localdomain.by \
--to=sergey.senozhatsky@mail.by \
--cc=ebiederm@xmission.com \
--cc=gregkh@suse.de \
--cc=kay.sievers@vrfy.org \
--cc=linux-kernel@vger.kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®