From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1754969AbZHCMVu (ORCPT ); Mon, 3 Aug 2009 08:21:50 -0400 Received: (majordomo@vger.kernel.org) by vger.kernel.org id S1754943AbZHCMVs (ORCPT ); Mon, 3 Aug 2009 08:21:48 -0400 Received: from fgwmail6.fujitsu.co.jp ([192.51.44.36]:44895 "EHLO fgwmail6.fujitsu.co.jp" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1754939AbZHCMVq (ORCPT ); Mon, 3 Aug 2009 08:21:46 -0400 X-SecurityPolicyCheck-FJ: OK by FujitsuOutboundMailChecker v1.3.1 From: KOSAKI Motohiro To: David Rientjes Subject: Re: [patch -mm v2] mm: introduce oom_adj_child Cc: kosaki.motohiro@jp.fujitsu.com, KAMEZAWA Hiroyuki , Andrew Morton , Rik van Riel , Paul Menage , linux-kernel@vger.kernel.org, linux-mm@kvack.org In-Reply-To: References: <77df8765230d9f83859fde3119a2d60a.squirrel@webmail-b.css.fujitsu.com> Message-Id: <20090803212059.CC2C.A69D9226@jp.fujitsu.com> MIME-Version: 1.0 Content-Type: text/plain; charset="US-ASCII" Content-Transfer-Encoding: 7bit X-Mailer: Becky! ver. 2.50.07 [ja] Date: Mon, 3 Aug 2009 21:21:44 +0900 (JST) Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org > On Sat, 1 Aug 2009, KAMEZAWA Hiroyuki wrote: > > > Summarizing I think now ..... > > - rename mm->oom_adj as mm->effective_oom_adj > > - re-add per-thread oom_adj > > - update mm->effective_oom_adj based on per-thread oom_adj > > - if necessary, plz add read-only /proc/pid/effective_oom_adj file. > > or show 2 values in /proc/pid/oom_adj > > - rewrite documentation about oom_score. > > " it's calclulated from _process's_ memory usage and oom_adj of > > all threads which shares a memor context". > > This behavior is not changed from old implemtation, anyway. > > - If necessary, rewrite oom_kill itself to scan only thread group > > leader. It's a way to go regardless of vfork problem. > > > > Ok, so you've abandoned the signal_struct proposal and now want to add it > back to task_struct with an effective member in mm_struct by changing the > documentation. Hmm. Oops, please see From line. The page was made from me ;)