mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Pavel Machek <pavel@ucw.cz>
To: Zhang Rui <rui.zhang@intel.com>
Cc: Linux Kernel Mailing List <linux-kernel@vger.kernel.org>,
	linux-pm <linux-pm@lists.linux-foundation.org>,
	linux-acpi <linux-acpi@vger.kernel.org>,
	"Rafael J. Wysocki" <rjw@sisk.pl>, Len Brown <lenb@kernel.org>,
	Alan Stern <stern@rowland.harvard.edu>,
	Arjan van de Ven <arjan@linux.intel.com>,
	"dtor@mail.ru" <dtor@mail.ru>
Subject: Re: [PATCH V2 4/4] i8042: support async suspend and shutdown
Date: Tue, 4 Aug 2009 15:46:09 +0200	[thread overview]
Message-ID: <20090804134609.GK18974@elf.ucw.cz> (raw)
In-Reply-To: <1249291590.2670.263.camel@rzhang-dt>


> > >  	panic_blink = i8042_panic_blink;
> > >  
> > >  	return 0;
> > >  
> > > + err_dev_async_unregister:
> > > +	dev_async_unregister(&i8042_platform_device->dev);
> > >   err_free_device:
> > >  	platform_device_put(i8042_platform_device);
> > >   err_unregister_driver:
> > 
> > I still do not like the interface: manually unregistering seems to be
> > ugly & error prone.
> > 
> hmm, yes, we can check device->dev_async and unregister it in driver
> core, at device_unregister time.
> 
> then I think we should rename the interfaces to:
> device_enable_async_action(dev, type),
> and device_disable_async_action(dev)
> so that they are more like driver core helper functions.
> what do you think?

Yes, that would be nicer.
									Pavel
-- 
(english) http://www.livejournal.com/~pavelmachek
(cesky, pictures) http://atrey.karlin.mff.cuni.cz/~pavel/picture/horses/blog.html

      reply	other threads:[~2009-08-04 13:46 UTC|newest]

Thread overview: 4+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2009-07-24  3:02 Zhang Rui
2009-07-24  7:14 ` Pavel Machek
2009-08-03  9:26   ` Zhang Rui
2009-08-04 13:46     ` Pavel Machek [this message]

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20090804134609.GK18974@elf.ucw.cz \
    --to=pavel@ucw.cz \
    --cc=arjan@linux.intel.com \
    --cc=dtor@mail.ru \
    --cc=lenb@kernel.org \
    --cc=linux-acpi@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-pm@lists.linux-foundation.org \
    --cc=rjw@sisk.pl \
    --cc=rui.zhang@intel.com \
    --cc=stern@rowland.harvard.edu \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®