From: KOSAKI Motohiro <kosaki.motohiro@jp.fujitsu.com>
To: Frederic Weisbecker <fweisbec@gmail.com>
Cc: kosaki.motohiro@jp.fujitsu.com, Anton Blanchard <anton@samba.org>,
Li Zefan <lizf@cn.fujitsu.com>, Zhaolei <zhaolei@cn.fujitsu.com>,
Lai Jiangshan <laijs@cn.fujitsu.com>, Ingo Molnar <mingo@elte.hu>,
Steven Rostedt <rostedt@goodmis.org>,
linux-kernel@vger.kernel.org
Subject: Re: [PATCH 2/2] tracing/workqueue: Rename workqueue_execute to worklet_entry and add worklet_exit
Date: Thu, 24 Sep 2009 09:22:37 +0900 (JST) [thread overview]
Message-ID: <20090924092023.B645.A69D9226@jp.fujitsu.com> (raw)
In-Reply-To: <20090922203414.GA5059@nowhere>
Hi
> In Kosaki's patch, we had the work struct address displayed too.
> Your version is supposed to be sufficient because we know a workqueue
> serializes its works. Then we know that an exit event will always follow
> and match the previous entry event from the same workqueue thread.
> The workqueue pid then provides a sufficient key for that.
>
> That said, we should worry about possible lost events from
> perf in some circumstances. And userspace profiling needs something
> to ensure the accuracy about this entry/exit pair.
>
> We could have:
> entry work1
> exit work 1 <--- lost event
> entry work2 <--- lost event
> exit work2
>
> And then the pair would be misinterpreted.
>
> (Although we could have even other misinterpretation
> with other kind of scenarios, even if we have this work
> address. But that's still more safety).
>
> So I'd prefer to keep Kosaki's idea about these keys.
> But I prefer your event naming.
>
> May be I can unearth Kosaki's patch, change it with your naming
> and add your Signed-off-by?
>
> Kosaki, no problem about it?
Sure.
Thank you paid attention my patch :-)
next prev parent reply other threads:[~2009-09-24 0:22 UTC|newest]
Thread overview: 7+ messages / expand[flat|nested] mbox.gz Atom feed top
2009-09-22 2:39 [PATCH 0/2] tracing/workqueue fixes Anton Blanchard
2009-09-22 2:40 ` [PATCH 1/2] tracing/workqueue: Use %pf in workqueue trace events Anton Blanchard
2009-09-22 2:42 ` [PATCH 2/2] tracing/workqueue: Rename workqueue_execute to worklet_entry and add worklet_exit Anton Blanchard
2009-09-22 20:34 ` Frederic Weisbecker
2009-09-24 0:22 ` KOSAKI Motohiro [this message]
2009-09-22 20:35 ` [PATCH 1/2] tracing/workqueue: Use %pf in workqueue trace events Frederic Weisbecker
2009-09-23 9:04 ` [tip:tracing/urgent] " tip-bot for Anton Blanchard
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20090924092023.B645.A69D9226@jp.fujitsu.com \
--to=kosaki.motohiro@jp.fujitsu.com \
--cc=anton@samba.org \
--cc=fweisbec@gmail.com \
--cc=laijs@cn.fujitsu.com \
--cc=linux-kernel@vger.kernel.org \
--cc=lizf@cn.fujitsu.com \
--cc=mingo@elte.hu \
--cc=rostedt@goodmis.org \
--cc=zhaolei@cn.fujitsu.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®