mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Ingo Molnar <mingo@elte.hu>
To: Dimitri Sivanich <sivanich@sgi.com>
Cc: linux-kernel@vger.kernel.org, "H. Peter Anvin" <hpa@zytor.com>,
	Thomas Gleixner <tglx@linutronix.de>
Subject: Re: [PATCH] x86 UV: Fixes for UV rtc timers
Date: Mon, 12 Oct 2009 19:59:20 +0200	[thread overview]
Message-ID: <20091012175920.GB17138@elte.hu> (raw)
In-Reply-To: <20091012175233.GA8129@sgi.com>


* Dimitri Sivanich <sivanich@sgi.com> wrote:

> On Mon, Oct 12, 2009 at 06:23:17PM +0200, Ingo Molnar wrote:
> > hm, why is the (unnecessary seeming) pushing of the 
> > ack/exit_idle()/irq_enter()/irq_exit() sequence into the 
> > generic_interrupt_extension() function a cleanup?
> 
> It seems to make more sense to allow the users of generic_interrupt to 
> provide their own sequence, rather than being forced into this one.

An IRQ handler is an irq handler. We should make it _more_ generic, not 
less generic.

Also, the generic_interrupt_extension() name sucks a bit. Something like 
x86_platform_ipi_callback() would be better.

> > Also, the commit log is rather terse - what is being fixed and why isnt 
> > it separate from any cleanups?
> 
> I have added to the commit log.  See below.

Please separate out the fix and do the cleanups on top of that.

Thanks,

	Ingo

  reply	other threads:[~2009-10-12 18:00 UTC|newest]

Thread overview: 13+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2009-10-09 13:47 Dimitri Sivanich
2009-10-12 16:23 ` Ingo Molnar
2009-10-12 17:52   ` Dimitri Sivanich
2009-10-12 17:59     ` Ingo Molnar [this message]
2009-10-14 14:14       ` [PATCH 0/4 v2] X86: UV RTC fixes/cleanup Dimitri Sivanich
2009-10-14 14:16         ` [PATCH 1/4 v2] X86: UV RTC fix early expiry handling Dimitri Sivanich
2009-10-14 14:18           ` [PATCH 2/4 v2] X86: UV RTC add clocksource only boot option Dimitri Sivanich
2009-10-14 14:21             ` [PATCH 3/4 v2] X86: UV RTC cleanup error handling Dimitri Sivanich
2009-10-14 14:22               ` [PATCH 4/4 v2] X86: UV RTC rename generic_interrupt Dimitri Sivanich
2009-10-14 16:33                 ` [tip:x86/uv] x86: UV RTC: Rename generic_interrupt to x86_platform_ipi tip-bot for Dimitri Sivanich
2009-10-14 16:33               ` [tip:x86/uv] x86: UV RTC: Clean up error handling tip-bot for Dimitri Sivanich
2009-10-14 16:33             ` [tip:x86/uv] x86: UV RTC: Add clocksource only boot option tip-bot for Dimitri Sivanich
2009-10-14 16:32           ` [tip:x86/uv] x86: UV RTC: Fix early expiry handling tip-bot for Dimitri Sivanich

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20091012175920.GB17138@elte.hu \
    --to=mingo@elte.hu \
    --cc=hpa@zytor.com \
    --cc=linux-kernel@vger.kernel.org \
    --cc=sivanich@sgi.com \
    --cc=tglx@linutronix.de \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®