From: Ingo Molnar <mingo@elte.hu>
To: Frederic Weisbecker <fweisbec@gmail.com>
Cc: LKML <linux-kernel@vger.kernel.org>,
Peter Zijlstra <peterz@infradead.org>,
Arnaldo Carvalho de Melo <acme@redhat.com>,
Mike Galbraith <efault@gmx.de>, Paul Mackerras <paulus@samba.org>,
Steven Rostedt <rostedt@goodmis.org>
Subject: Re: [PATCH 3/2] perf tools: Use DECLARE_BITMAP instead of an open-coded array
Date: Mon, 19 Oct 2009 09:30:39 +0200 [thread overview]
Message-ID: <20091019073039.GC17960@elte.hu> (raw)
In-Reply-To: <20091017160338.GA10344@nowhere>
* Frederic Weisbecker <fweisbec@gmail.com> wrote:
> On Sat, Oct 17, 2009 at 05:57:18PM +0200, Frederic Weisbecker wrote:
> > Use DECLARE_BITMAP instead of an open coded array for our bitmap
> > of featured sections.
> >
> > This makes the array an unsigned long instead of a u64 but since we
> > use a 256 bits bitmap, the array size shouldn't vary between
> > different boxes.
>
> That said I would really feel more comfortable if someone can confirm
> that.
Should be size-invariant for the bitmap size of 256 bits due to:
#define DECLARE_BITMAP(name,bits) \
unsigned long name[BITS_TO_LONGS(bits)]
but it's not little-endian/big-endian invariant.
We should at minimum save the CPU architecture (and endianness
parameters) the data got generated on, and reject
endianness-incompatible uses - so that if someone wants to add
cross-endian support it can be implemented cleanly.
Ingo
next prev parent reply other threads:[~2009-10-19 7:30 UTC|newest]
Thread overview: 13+ messages / expand[flat|nested] mbox.gz Atom feed top
2009-10-15 21:10 [PATCH] perf tools: Add a new generic section in perf.data Frederic Weisbecker
2009-10-16 7:10 ` Ingo Molnar
2009-10-16 7:33 ` Frederic Weisbecker
2009-10-16 7:42 ` Ingo Molnar
2009-10-17 15:12 ` [PATCH 1/2] perf tools: Use kernel bitmap library Frederic Weisbecker
2009-10-19 7:55 ` [tip:perf/core] " tip-bot for Frederic Weisbecker
2009-10-17 15:12 ` [PATCH 2/2] perf tools: Introduce bitmask'ed additional headers Frederic Weisbecker
2009-10-19 7:56 ` [tip:perf/core] " tip-bot for Frederic Weisbecker
2009-10-17 15:57 ` [PATCH 3/2] perf tools: Use DECLARE_BITMAP instead of an open-coded array Frederic Weisbecker
2009-10-17 16:03 ` Frederic Weisbecker
2009-10-19 7:30 ` Ingo Molnar [this message]
2009-10-19 19:40 ` Frederic Weisbecker
2009-10-19 7:56 ` [tip:perf/core] " tip-bot for Frederic Weisbecker
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20091019073039.GC17960@elte.hu \
--to=mingo@elte.hu \
--cc=acme@redhat.com \
--cc=efault@gmx.de \
--cc=fweisbec@gmail.com \
--cc=linux-kernel@vger.kernel.org \
--cc=paulus@samba.org \
--cc=peterz@infradead.org \
--cc=rostedt@goodmis.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®