mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Thadeu Lima de Souza Cascardo <cascardo@holoscopio.com>
To: Andrew Morton <akpm@linux-foundation.org>
Cc: linux-kernel@vger.kernel.org, device@lanana.org,
	rubini@vision.unipv.it, gregkh@suse.de, cluster-devel@redhat.com
Subject: Re: [PATCH] misc: use a proper range for minor number dynamic allocation
Date: Mon, 9 Nov 2009 21:29:25 -0200	[thread overview]
Message-ID: <20091109232922.GF12217@vespa.holoscopio.com> (raw)
In-Reply-To: <20091109220257.GD12217@vespa.holoscopio.com>

[-- Attachment #1: Type: text/plain, Size: 1631 bytes --]

On Mon, Nov 09, 2009 at 08:02:57PM -0200, Thadeu Lima de Souza Cascardo wrote:
> > 
> > Is that a bugfix for the existing code?
> > 
> > If so, please split that out into a separate patch which we can review
> > and apply promptly while we consider the broader problem which you've
> > identified.
> 
> We could consider buggy the caller which asks for the same device name
> more than once, without unregistering the first device. But better safe
> than sorry: we should protect the correct drivers from the buggy ones
> and avoid a depletion of the minor numbers. And, in case the driver core
> returns another error for another reason (from device_create), we do the
> right thing.
> 
> I will send it right now.
> 
> Regards,
> Cascardo.

I've just tried to create a single and separate patch, but that would
let lots of related bugs around.

First of all, the current code does not use the bitmap idiom. Should I
use it on my fix and let all the other bitmap manipulations as is, or
should I use the current and less readable style?

Second, this single fix would match the same test currently in
misc_deregister, which is broken, since it does not test for the 0
minor.

Thus, I am sending a patch which fixes those two issues using the
current style, a fix for the style itself, and a change from the current
range to something that could have its range easily fixed. However,
regarding that last change, it will still use bitmaps, which may not be
appropriate for large ranges.

Perhaps, using a idr instead of the list and bitmap couple, may be
sensible. What do you think about it?

[-- Attachment #2: Digital signature --]
[-- Type: application/pgp-signature, Size: 197 bytes --]

  reply	other threads:[~2009-11-09 23:29 UTC|newest]

Thread overview: 12+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2009-10-23 23:28 Thadeu Lima de Souza Cascardo
2009-11-03 12:05 ` Alessandro Rubini
2009-11-09 21:28 ` Andrew Morton
2009-11-09 21:32   ` H. Peter Anvin
2009-11-09 22:02   ` Thadeu Lima de Souza Cascardo
2009-11-09 23:29     ` Thadeu Lima de Souza Cascardo [this message]
2009-11-09 23:40       ` Andrew Morton
2009-11-10 11:09     ` Alan Cox
2009-11-10 17:15       ` Thadeu Lima de Souza Cascardo
2009-11-09 23:03   ` [Cluster-devel] " David Teigland
2009-11-10 11:10     ` Steven Whitehouse
2009-11-10 11:16       ` Alan Cox

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20091109232922.GF12217@vespa.holoscopio.com \
    --to=cascardo@holoscopio.com \
    --cc=akpm@linux-foundation.org \
    --cc=cluster-devel@redhat.com \
    --cc=device@lanana.org \
    --cc=gregkh@suse.de \
    --cc=linux-kernel@vger.kernel.org \
    --cc=rubini@vision.unipv.it \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®