From: Andi Kleen <andi@firstfloor.org>
To: Stefani Seibold <stefani@seibold.net>
Cc: Andrew Morton <akpm@linux-foundation.org>,
linux-kernel <linux-kernel@vger.kernel.org>,
Arnd Bergmann <arnd@arndb.de>, Andi Kleen <andi@firstfloor.org>,
Amerigo Wang <xiyou.wangcong@gmail.com>,
Joe Perches <joe@perches.com>,
Roger Quadros <quadros.roger@gmail.com>,
Greg Kroah-Hartman <gregkh@suse.de>,
Mauro Carvalho Chehab <mchehab@redhat.com>
Subject: Re: [PATCH 7/7] kfifo: add record handling functions
Date: Thu, 26 Nov 2009 17:44:14 +0100 [thread overview]
Message-ID: <20091126164414.GK29096@one.firstfloor.org> (raw)
In-Reply-To: <1259251632.26705.17.camel@wall-e>
On Thu, Nov 26, 2009 at 05:07:12PM +0100, Stefani Seibold wrote:
> I analyzed the code and most of them will be optimized away by the
> compiler. The reason for this design decision was that i want no
> performance regression against the old kfifo implementation.
>
> But if the majority vote for an non inline version i will do it. It will
> make the code more readable and slim down the footprint.
I vote for smaller text size if possible. I doubt kfifo is used in any
circumstances where a function call or two is a big problem. But of course
some inlines might be smaller than calls.
But then this code has been pending for a long time and I
have some potential users. It would be good to merge ASAP and do such tweaks
later in tree.
-Andi
--
ak@linux.intel.com -- Speaking for myself only.
next prev parent reply other threads:[~2009-11-26 16:44 UTC|newest]
Thread overview: 19+ messages / expand[flat|nested] mbox.gz Atom feed top
2009-11-20 8:15 [PATCH 0/7] kfifo: new API v0.7 Stefani Seibold
2009-11-20 8:18 ` [PATCH 1/7] kfifo: move struct kfifo in place Stefani Seibold
2009-11-20 8:20 ` [PATCH 2/7] kfifo: move out spinlock Stefani Seibold
2009-11-20 8:22 ` [PATCH 3/7] kfifo: cleanup namespace Stefani Seibold
2009-11-20 8:25 ` [PATCH 4/7] kfifo: rename kfifo_put... into kfifo_in... and kfifo_get... into kfifo_out Stefani Seibold
2009-11-20 8:27 ` [PATCH 5/7] kfifo: add DEFINE_KFIFO and friends, add very tiny functions Stefani Seibold
2009-11-23 22:19 ` Andrew Morton
2009-11-24 6:52 ` Stefani Seibold
2009-11-24 23:29 ` Andrew Morton
2009-11-20 8:29 ` [PATCH 6/7] kfifo: add kfifo_skip, kfifo_from_user and kfifo_to_user Stefani Seibold
2009-11-20 8:33 ` [PATCH 7/7] kfifo: add record handling functions Stefani Seibold
2009-11-23 22:19 ` Andrew Morton
2009-11-24 6:52 ` Stefani Seibold
2009-11-26 16:07 ` Stefani Seibold
2009-11-26 16:44 ` Andi Kleen [this message]
2009-11-29 16:17 ` [PATCH 0/7] kfifo: new API v0.7 Thiago Farina
-- strict thread matches above, loose matches on Subject: below --
2009-11-16 11:50 [PATCH 0/7] kfifo: new API v0.6 Stefani Seibold
2009-11-16 12:07 ` [PATCH 7/7] kfifo: add record handling functions Stefani Seibold
2009-08-19 20:49 [PATCH 0/7] kfifo: new API v0.5 Stefani Seibold
2009-08-19 21:06 ` [PATCH 7/7] kfifo: add record handling functions Stefani Seibold
2009-08-16 20:39 [PATCH 0/7] kfifo: new API v0.4 Stefani Seibold
2009-08-16 21:04 ` [PATCH 7/7] kfifo: add record handling functions Stefani Seibold
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20091126164414.GK29096@one.firstfloor.org \
--to=andi@firstfloor.org \
--cc=akpm@linux-foundation.org \
--cc=arnd@arndb.de \
--cc=gregkh@suse.de \
--cc=joe@perches.com \
--cc=linux-kernel@vger.kernel.org \
--cc=mchehab@redhat.com \
--cc=quadros.roger@gmail.com \
--cc=stefani@seibold.net \
--cc=xiyou.wangcong@gmail.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®