mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: KOSAKI Motohiro <kosaki.motohiro@jp.fujitsu.com>
To: Andrew Morton <akpm@linux-foundation.org>
Cc: kosaki.motohiro@jp.fujitsu.com,
	LKML <linux-kernel@vger.kernel.org>,
	linux-mm <linux-mm@kvack.org>
Subject: Re: [PATCH 1/4] vmscan: more simplify shrink_inactive_list()
Date: Fri,  4 Dec 2009 17:26:50 +0900 (JST)	[thread overview]
Message-ID: <20091204172429.5889.A69D9226@jp.fujitsu.com> (raw)
In-Reply-To: <20091127091357.A7CC.A69D9226@jp.fujitsu.com>

> This patch depend on "vmscan : simplify code" patch (written by Huang Shijie)
> 
> =========================================
> Now, max_scan of shrink_inactive_list() is always passed less than
> SWAP_CLUSTER_MAX. then, we can remove scanning pages loop in it.
> 
> detail
>  - remove "while (nr_scanned < max_scan)" loop
>  - remove nr_freed variable (now, we use nr_reclaimed directly)
>  - remove nr_scan variable (now, we use nr_scanned directly)
>  - rename max_scan to nr_to_scan
>  - pass nr_to_scan into isolate_pages() directly instead
>    using SWAP_CLUSTER_MAX

Andrew, please don't pick up this patch series awhile. I and some vmscan
folks are working on fixing Larry's AIM7 problem. it is important than this
and it might makes conflict against this.

I'll rebase this patch series awhile after.




  parent reply	other threads:[~2009-12-04  8:26 UTC|newest]

Thread overview: 16+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2009-11-27  0:17 KOSAKI Motohiro
2009-11-27  0:18 ` [PATCH 2/4] vmscan: make lru_index() helper function KOSAKI Motohiro
2009-11-27  5:44   ` Vincent Li
2009-11-27  5:47     ` KOSAKI Motohiro
2009-11-27  5:54       ` Vincent Li
2009-11-27  0:19 ` [PATCH 3/4] vmscan: move PGDEACTIVATE modification to shrink_active_list() KOSAKI Motohiro
2009-11-27  0:23 ` [RFC][PATCH 4/4] vmscan: vmscan don't use pcp list KOSAKI Motohiro
2009-11-27 16:17   ` Mel Gorman
2009-12-02  7:15     ` KOSAKI Motohiro
2009-12-02 14:25       ` Mel Gorman
2009-11-27 19:25   ` Christoph Lameter
2009-12-04  8:26 ` KOSAKI Motohiro [this message]
2009-12-06  4:19 ` [PATCH 1/4] vmscan: more simplify shrink_inactive_list() Wu Fengguang
2009-12-07  5:48   ` KOSAKI Motohiro
2009-12-06  5:41 ` [PATCH] vmscan: aligned scan batching Wu Fengguang
2009-12-07  6:17   ` KOSAKI Motohiro

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20091204172429.5889.A69D9226@jp.fujitsu.com \
    --to=kosaki.motohiro@jp.fujitsu.com \
    --cc=akpm@linux-foundation.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-mm@kvack.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®