From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S932955Ab0AFWAi (ORCPT ); Wed, 6 Jan 2010 17:00:38 -0500 Received: (majordomo@vger.kernel.org) by vger.kernel.org id S932946Ab0AFWAh (ORCPT ); Wed, 6 Jan 2010 17:00:37 -0500 Received: from outbound-mail-10.bluehost.com ([69.89.17.210]:34583 "HELO outbound-mail-10.bluehost.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with SMTP id S932917Ab0AFWAf (ORCPT ); Wed, 6 Jan 2010 17:00:35 -0500 DomainKey-Signature: a=rsa-sha1; q=dns; c=nofws; s=default; d=virtuousgeek.org; h=Received:Date:From:To:Cc:Subject:Message-ID:In-Reply-To:References:X-Mailer:Mime-Version:Content-Type:Content-Transfer-Encoding:X-Identified-User; b=WpMFyL66+pe/PEOiLXNcLLweXxzTSou2SimwNGfX+YYCP+7zJgKsim4qWpmun4S1zuryPpilF/LwS4B8p6V0rtBDtexBVXaiYOgUH9rB/MdbubkBqk7ZV2APJebSJa8Y; Date: Wed, 6 Jan 2010 14:00:35 -0800 From: Jesse Barnes To: "Rafael J. Wysocki" Cc: Matthew Garrett , Len Brown , LKML , pm list , Alan Stern , ACPI Devel Maling List , Linux PCI , Oliver Neukum , Bjorn Helgaas , Shaohua Li , Francois Romieu Subject: Re: [PATCH 9/12] ACPI / PM: Introduce acpi_pm_wakeup_power() Message-ID: <20100106140035.6f622acf@jbarnes-piketon> In-Reply-To: <200912272106.26569.rjw@sisk.pl> References: <200912272057.10443.rjw@sisk.pl> <200912272106.26569.rjw@sisk.pl> X-Mailer: Claws Mail 3.7.2 (GTK+ 2.18.3; x86_64-pc-linux-gnu) Mime-Version: 1.0 Content-Type: text/plain; charset=US-ASCII Content-Transfer-Encoding: 7bit X-Identified-User: {10642:box514.bluehost.com:virtuous:virtuousgeek.org} {sentby:smtp auth 75.111.28.251 authed with jbarnes@virtuousgeek.org} Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org On Sun, 27 Dec 2009 21:06:26 +0100 "Rafael J. Wysocki" wrote: > /** > + * acpi_pm_wakeup_power - Enable/disable device wake-up power. > + * @dev: ACPI device to handle. > + * @enable: Whether to enable or disable the wake-up power of the > device. > + */ > +int acpi_pm_wakeup_power(struct acpi_device *dev, bool enable) > +{ I know we've got these all over now, but functions that just take a bool are generally hard to read when you just look at the call site. If it was called "acpi_pm_set_wakeup_power" and then took an on/off enum it would be really easy to see, from the callsite, what was going on. It's a fairly minor complaint, but it's something that's always bugged me about the PCI PM code in particular. -- Jesse Barnes, Intel Open Source Technology Center