From: "Rafael J. Wysocki" <rjw@sisk.pl>
To: Jesse Barnes <jbarnes@virtuousgeek.org>
Cc: Matthew Garrett <mjg@redhat.com>, Len Brown <lenb@kernel.org>,
LKML <linux-kernel@vger.kernel.org>,
pm list <linux-pm@lists.linux-foundation.org>,
Alan Stern <stern@rowland.harvard.edu>,
ACPI Devel Maling List <linux-acpi@vger.kernel.org>,
Linux PCI <linux-pci@vger.kernel.org>,
Oliver Neukum <oliver@neukum.org>,
Bjorn Helgaas <bjorn.helgaas@hp.com>,
Shaohua Li <shaohua.li@intel.com>,
Francois Romieu <romieu@fr.zoreil.com>
Subject: Re: [PATCH 9/12] ACPI / PM: Introduce acpi_pm_wakeup_power()
Date: Thu, 7 Jan 2010 22:11:50 +0100 [thread overview]
Message-ID: <201001072211.50224.rjw@sisk.pl> (raw)
In-Reply-To: <201001070011.49755.rjw@sisk.pl>
On Thursday 07 January 2010, Rafael J. Wysocki wrote:
> On Wednesday 06 January 2010, Jesse Barnes wrote:
> > On Sun, 27 Dec 2009 21:06:26 +0100
> > "Rafael J. Wysocki" <rjw@sisk.pl> wrote:
> > > /**
> > > + * acpi_pm_wakeup_power - Enable/disable device wake-up power.
> > > + * @dev: ACPI device to handle.
> > > + * @enable: Whether to enable or disable the wake-up power of the
> > > device.
> > > + */
> > > +int acpi_pm_wakeup_power(struct acpi_device *dev, bool enable)
> > > +{
> >
> > I know we've got these all over now, but functions that just take a
> > bool are generally hard to read when you just look at the call site.
> > If it was called "acpi_pm_set_wakeup_power" and then took an on/off
> > enum it would be really easy to see, from the callsite, what was going
> > on.
> >
> > It's a fairly minor complaint, but it's something that's always bugged
> > me about the PCI PM code in particular.
>
> Well, in this particular case acpi_pm_wakeup_power() uses a bool, because
> acpi_pm_device_sleep_wake() (which is a caller of it) does. IMO it won't
> be logical to use something else just here.
>
> Also, as you noticed above, this follows a convention used not only in the
> PCI PM, but generally in the core PM code. Although we could change this
> convention, I'm not really sure that would be worth the effort.
That said, it looks like we can drop this (ie. [9/12]) patch altogether if the
next one is changed slightly.
I'll post the modified [10/12] shortly.
Rafael
next prev parent reply other threads:[~2010-01-07 21:11 UTC|newest]
Thread overview: 34+ messages / expand[flat|nested] mbox.gz Atom feed top
2009-12-27 19:57 [PATCH 0/12] PCI run-time PM support (rev. 2) Rafael J. Wysocki
2009-12-27 19:59 ` [PATCH 1/12] PCI PM: Add function for checking PME status of devices Rafael J. Wysocki
2010-01-06 21:46 ` Jesse Barnes
2009-12-27 20:00 ` [PATCH 2/12] PCI / PM: Propagate wake-up enable for PCIe devices too Rafael J. Wysocki
2010-01-04 23:40 ` Jesse Barnes
2010-01-05 21:27 ` Rafael J. Wysocki
2009-12-27 20:01 ` [PATCH 3/12] PCI PM: PCIe PME root port service driver (rev. 5) Rafael J. Wysocki
2010-01-06 21:53 ` Jesse Barnes
2009-12-27 20:02 ` [PATCH 4/12] PCI PM: Make it possible to force using INTx for PCIe PME signaling Rafael J. Wysocki
2010-01-06 21:56 ` Jesse Barnes
2010-01-06 22:02 ` Matthew Garrett
2010-01-06 23:00 ` Rafael J. Wysocki
2010-01-08 20:08 ` Len Brown
2010-01-08 20:25 ` Greg KH
2009-12-27 20:03 ` [PATCH 5/12] ACPI: Add infrastructure for refcounting GPE consumers Rafael J. Wysocki
2009-12-27 20:03 ` [PATCH 6/12] ACPI: Add support for new refcounted GPE API to drivers Rafael J. Wysocki
2009-12-27 20:04 ` [PATCH 7/12] ACPI: Remove old GPE API and transition code entirely to new one Rafael J. Wysocki
2009-12-27 20:05 ` [PATCH 8/12] ACPI / PM: Add more run-time wake-up fields Rafael J. Wysocki
2010-01-08 20:39 ` Len Brown
2010-01-08 23:27 ` Rafael J. Wysocki
2009-12-27 20:06 ` [PATCH 9/12] ACPI / PM: Introduce acpi_pm_wakeup_power() Rafael J. Wysocki
2010-01-06 22:00 ` Jesse Barnes
2010-01-06 23:11 ` Rafael J. Wysocki
2010-01-07 21:11 ` Rafael J. Wysocki [this message]
2009-12-27 20:07 ` [PATCH 10/12] PCI / ACPI / PM: Platform support for PCI PME wake-up (rev. 6) Rafael J. Wysocki
2010-01-06 22:04 ` Jesse Barnes
2010-01-07 21:18 ` Rafael J. Wysocki
2009-12-27 20:08 ` [PATCH 11/12] PCI PM: Run-time callbacks for PCI bus type (rev. 2) Rafael J. Wysocki
2010-01-06 22:06 ` Jesse Barnes
2009-12-27 20:11 ` [PATCH 12/12] PM / r8169: Add simplified run-time PM support Rafael J. Wysocki
2010-01-01 19:06 ` [PATCH 12/12] PM / r8169: Add simplified run-time PM support (rev. 2) Rafael J. Wysocki
2010-01-01 1:29 ` [PATCH][RFC] e1000e: Add basic runtime PM support (was: [PATCH 0/12] PCI run-time PM support (rev. 2)) Rafael J. Wysocki
2010-01-01 19:03 ` [PATCH][RFC] e1000e: Add basic runtime PM support (rev. 2) " Rafael J. Wysocki
2010-01-01 21:51 ` [PATCH][RFC] e1000e: Add basic runtime PM support (rev. 3) " Rafael J. Wysocki
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=201001072211.50224.rjw@sisk.pl \
--to=rjw@sisk.pl \
--cc=bjorn.helgaas@hp.com \
--cc=jbarnes@virtuousgeek.org \
--cc=lenb@kernel.org \
--cc=linux-acpi@vger.kernel.org \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-pci@vger.kernel.org \
--cc=linux-pm@lists.linux-foundation.org \
--cc=mjg@redhat.com \
--cc=oliver@neukum.org \
--cc=romieu@fr.zoreil.com \
--cc=shaohua.li@intel.com \
--cc=stern@rowland.harvard.edu \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®