From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1754261Ab0AHX0v (ORCPT ); Fri, 8 Jan 2010 18:26:51 -0500 Received: (majordomo@vger.kernel.org) by vger.kernel.org id S1754228Ab0AHX0u (ORCPT ); Fri, 8 Jan 2010 18:26:50 -0500 Received: from ogre.sisk.pl ([217.79.144.158]:52865 "EHLO ogre.sisk.pl" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1754145Ab0AHX0t (ORCPT ); Fri, 8 Jan 2010 18:26:49 -0500 From: "Rafael J. Wysocki" To: Len Brown Subject: Re: [PATCH 8/12] ACPI / PM: Add more run-time wake-up fields Date: Sat, 9 Jan 2010 00:27:08 +0100 User-Agent: KMail/1.12.3 (Linux/2.6.33-rc3-rjw; KDE/4.3.3; x86_64; ; ) Cc: Jesse Barnes , Matthew Garrett , LKML , pm list , Alan Stern , ACPI Devel Maling List , Linux PCI , Oliver Neukum , Bjorn Helgaas , Shaohua Li , Francois Romieu References: <200912272057.10443.rjw@sisk.pl> <200912272105.30352.rjw@sisk.pl> In-Reply-To: MIME-Version: 1.0 Content-Type: Text/Plain; charset="iso-8859-1" Content-Transfer-Encoding: 7bit Message-Id: <201001090027.08609.rjw@sisk.pl> Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org On Friday 08 January 2010, Len Brown wrote: > > Use the run_wake flag to mark all devices for which run-time wake-up > > events may be generated by the platform. Introduce a new wake-up > > flag, special, for marking devices that should be permanently enabled > > to generate run-time events. > > how about calling the flag "always_enabled" rather than "special"? OK, I'll do that. > otherwise, > Acked-by: Len Brown Thanks!