From: "Uwe Kleine-König" <u.kleine-koenig@pengutronix.de>
To: Alberto Panizzo <maramaopercheseimorto@gmail.com>
Cc: Mark Brown <broonie@opensource.wolfsonmicro.com>,
Samuel Ortiz <sameo@linux.intel.com>,
Liam Girdwood <lrg@slimlogic.co.uk>,
Sascha linux-arm <s.hauer@pengutronix.de>,
linux-kernel <linux-kernel@vger.kernel.org>,
linux-arm-kernel-infradead <linux-arm-kernel@lists.infradead.org>
Subject: Re: [PATCH] regulator: mc13783: consider Power Gates as digital regulators.
Date: Mon, 18 Jan 2010 20:04:46 +0100 [thread overview]
Message-ID: <20100118190445.GA16989@pengutronix.de> (raw)
In-Reply-To: <1263830523.3632.22.camel@realization>
Hello Alberto,
Can you post an updated patch addressing the discussion with Mark,
please?
>From the first look I don't like the name
MC13783_REG_POWERMISC_PWGTSPI_M as I don't understand it's purpose
without going through mc13783_reg_rmw_powermisc (which I didn't do yet).
What is the base for your patch? (Hm, it seems next could work.
mc13783-regulator seems to have gotten some more #defines ending in _M.
You seem to mean "mask". IMHO it's a bit unfortunate, because the
nameing scheme doesn't match the already existing names :-()
Shouldn't mc13783_state_powermisc_pwgt be a per-device variable instead
of a static variable?
Best regards
Uwe
--
Pengutronix e.K. | Uwe Kleine-König |
Industrial Linux Solutions | http://www.pengutronix.de/ |
next prev parent reply other threads:[~2010-01-18 19:04 UTC|newest]
Thread overview: 10+ messages / expand[flat|nested] mbox.gz Atom feed top
2010-01-18 16:02 Alberto Panizzo
2010-01-18 16:32 ` Mark Brown
2010-01-18 17:26 ` Alberto Panizzo
2010-01-18 17:37 ` Mark Brown
[not found] ` <1263834473.3632.31.camel@realization>
[not found] ` <20100118172002.GB6889@rakim.wolfsonmicro.main>
2010-01-18 17:50 ` Alberto Panizzo
2010-01-18 17:56 ` Mark Brown
2010-01-18 19:04 ` Uwe Kleine-König [this message]
2010-01-18 21:01 ` Alberto Panizzo
2010-01-19 10:26 ` Liam Girdwood
2010-01-19 11:12 ` Alberto Panizzo
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20100118190445.GA16989@pengutronix.de \
--to=u.kleine-koenig@pengutronix.de \
--cc=broonie@opensource.wolfsonmicro.com \
--cc=linux-arm-kernel@lists.infradead.org \
--cc=linux-kernel@vger.kernel.org \
--cc=lrg@slimlogic.co.uk \
--cc=maramaopercheseimorto@gmail.com \
--cc=s.hauer@pengutronix.de \
--cc=sameo@linux.intel.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
Powered by JetHome