mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Haavard Skinnemoen <haavard.skinnemoen@atmel.com>
To: Denys Vlasenko <vda.linux@googlemail.com>
Cc: Michal Marek <mmarek@suse.cz>, Sam Ravnborg <sam@ravnborg.org>,
	Haavard Skinnemoen <hskinnemoen@atmel.com>,
	David Howells <dhowells@redhat.com>,
	linux-kernel@vger.kernel.org, Bjorn Wesen <bjornw@axis.com>,
	Tim Bird <tim.bird@am.sony.com>, Tim Abbott <tabbott@ksplice.com>,
	Anders Kaseorg <andersk@ksplice.com>,
	Waseem Daher <wdaher@ksplice.com>,
	Rusty Russell <rusty@rustcorp.com.au>,
	Andi Kleen <andi@firstfloor.org>,
	Stephen Rothwell <sfr@canb.auug.org.au>,
	"H. Peter Anvin" <hpa@zytor.com>,
	Denys Vlasenko <vda.linux@googlemail.com>
Subject: Re: [PATCH 17/24] Rename .text.reset to .text..reset.
Date: Mon, 1 Mar 2010 11:41:11 +0700	[thread overview]
Message-ID: <20100301114111.06234d49@hskinnemoen-d830> (raw)
In-Reply-To: <1266624237-22372-18-git-send-email-vda.linux@googlemail.com>

Denys Vlasenko <vda.linux@googlemail.com> wrote:
> diff --git a/arch/avr32/kernel/vmlinux.lds.S b/arch/avr32/kernel/vmlinux.lds.S
> index 9cd2bd9..5d7fe57 100644
> --- a/arch/avr32/kernel/vmlinux.lds.S
> +++ b/arch/avr32/kernel/vmlinux.lds.S
> @@ -26,7 +26,7 @@ SECTIONS
>  		_stext = .;
>  		__init_begin = .;
>  			_sinittext = .;
> -			*(.text.reset)
> +			*(.text..reset)

Please remove it instead. I'm sure there's no code which actually
places something in .text.reset, but if there is, this patch would
break it in exactly the same way as removing it altogether would do.

Haavard

  parent reply	other threads:[~2010-03-01  4:42 UTC|newest]

Thread overview: 34+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2010-02-20  0:03 [PATCH 00/24] Rename kernel's magic sections for compatibility with -ffunction-sections -fdata-sections Denys Vlasenko
2010-02-20  0:03 ` [PATCH 01/24] Rename .data.cacheline_aligned to .data..cacheline_aligned Denys Vlasenko
2010-02-20  0:03 ` [PATCH 02/24] Rename .data.init_task to .data..init_task Denys Vlasenko
2010-02-20  0:03 ` [PATCH 03/24] powerpc: remove unused __page_aligned definition Denys Vlasenko
2010-02-20  0:03 ` [PATCH 04/24] Rename .data.page_aligned to .data..page_aligned Denys Vlasenko
2010-02-20  0:03 ` [PATCH 05/24] Rename .bss.page_aligned to .bss..page_aligned Denys Vlasenko
2010-02-20  0:03 ` [PATCH 06/24] Rename .bss.stack to .bss..stack Denys Vlasenko
2010-02-20  0:03 ` [PATCH 07/24] Rename .data.gate to .data..gate Denys Vlasenko
2010-02-20  0:03 ` [PATCH 08/24] Rename .data.init_irqstack to .data..init_irqstack Denys Vlasenko
2010-02-20  0:03 ` [PATCH 11/24] Rename .data.read_mostly to .data..read_mostly Denys Vlasenko
2010-02-20  0:03 ` [PATCH 13/24] Rename .rodata.compressed to .rodata..compressed Denys Vlasenko
2010-02-20  0:03 ` [PATCH 14/24] Rename .text.ivt to .text..ivt Denys Vlasenko
2010-02-20  0:03 ` [PATCH 15/24] Rename .text.lock to .text..lock Denys Vlasenko
2010-02-20  0:03 ` [PATCH 16/24] Rename .text.page_aligned to .text..page_aligned Denys Vlasenko
2010-02-20  0:03 ` [PATCH 17/24] Rename .text.reset to .text..reset Denys Vlasenko
2010-03-01  2:31   ` Tim Abbott
2010-03-01  4:37     ` Haavard Skinnemoen
2010-03-01  4:41   ` Haavard Skinnemoen [this message]
2010-02-20  0:03 ` [PATCH 18/24] Rename .text.startup to .text..startup Denys Vlasenko
2010-02-20  0:03 ` [PATCH 19/24] Rename .data.nosave to .data..nosave Denys Vlasenko
2010-02-20  0:03 ` [PATCH 20/24] Rename .data.init to .data..init Denys Vlasenko
2010-02-20  0:03 ` [PATCH 21/24] Rename .data.initvect to .data..initvect Denys Vlasenko
2010-02-20  0:03 ` [PATCH 22/24] Rename .data.lock_aligned to .data..lock_aligned Denys Vlasenko
2010-02-20  0:03 ` [PATCH 24/24] Rename .text.start to .text..start Denys Vlasenko
2010-02-20  0:37 ` [PATCH 09/24] Rename .data..patch.xxx to .data..patch.xxx Denys Vlasenko
2010-02-20  0:37 ` [PATCH 10/24] Rename .data[.percpu][.xxx] to .data[..percpu][..xxx] Denys Vlasenko
2010-02-20  0:37 ` [PATCH 12/24] Rename .data.vmpages and .data.vm0.xxx to .data..vmpages and .data..vm0.xxx Denys Vlasenko
2010-02-20  0:45 ` [PATCH 23/24] Rename special text sections in arch/frv from .text.xxx to .text..xxx Denys Vlasenko
2010-02-20  9:22 ` [PATCH 00/24] Rename kernel's magic sections for compatibility with -ffunction-sections -fdata-sections Andi Kleen
2010-02-20 21:58   ` Denys Vlasenko
2010-03-01  4:03 ` Tim Abbott
2010-03-03 10:23   ` Michal Marek
2010-03-09 15:56   ` Mike Frysinger
2010-03-11 15:04 ` David Howells

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20100301114111.06234d49@hskinnemoen-d830 \
    --to=haavard.skinnemoen@atmel.com \
    --cc=andersk@ksplice.com \
    --cc=andi@firstfloor.org \
    --cc=bjornw@axis.com \
    --cc=dhowells@redhat.com \
    --cc=hpa@zytor.com \
    --cc=hskinnemoen@atmel.com \
    --cc=linux-kernel@vger.kernel.org \
    --cc=mmarek@suse.cz \
    --cc=rusty@rustcorp.com.au \
    --cc=sam@ravnborg.org \
    --cc=sfr@canb.auug.org.au \
    --cc=tabbott@ksplice.com \
    --cc=tim.bird@am.sony.com \
    --cc=vda.linux@googlemail.com \
    --cc=wdaher@ksplice.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®