On Wednesday 31 March 2010 19:07:54 David Howells wrote: > David Howells wrote: > > > how about putting this implementation into like vmap_nommu() and only > > > rewriting vmap() to vmap_nommu() when we know it's safe ? such as this > > > firmware case ? > > > > Well, I'd argue it's _not_ vmap(), so it doesn't really make sense to > > call it such. Perhaps some better name? Perhaps vcopy()? fair point > How about vcoalesce()? WFM, as does something like vmerge() ... -mike