mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Greg KH <greg@kroah.com>
To: "Uwe Kleine-König" <u.kleine-koenig@pengutronix.de>
Cc: linux-kernel@vger.kernel.org, Greg Kroah-Hartman <gregkh@suse.de>,
	Magnus Damm <damm@opensource.se>,
	"Rafael J. Wysocki" <rjw@sisk.pl>,
	Paul Mundt <lethal@linux-sh.org>, Dmitry Torokhov <dtor@mail.ru>,
	Eric Miao <eric.y.miao@gmail.com>,
	netdev@vger.kernel.org
Subject: Re: [PATCH 2/2] Driver core: reduce duplicated code
Date: Wed, 16 Jun 2010 13:53:32 -0700	[thread overview]
Message-ID: <20100616205332.GB15837@kroah.com> (raw)
In-Reply-To: <20100615090500.GA17595@pengutronix.de>

On Tue, Jun 15, 2010 at 11:05:00AM +0200, Uwe Kleine-König wrote:
> Hello,
> 
> On Tue, Jun 15, 2010 at 10:47:56AM +0200, Uwe Kleine-König wrote:
> > This makes the two similar functions platform_device_register_simple
> > and platform_device_register_data one line inline functions using a new
> > generic function platform_device_register_resndata.
> I forgot to add some comments to this mail, ... sorry.
> 
>  - I'm not completely happy with the name of the new function.  If
>    someone has a better name please tell me.

I don't like it either, what is "resndata" supposed to stand for?

>  - can platform_device_register_resndata be moved to __init_or_module?

I doubt it, but try it and see if a build warns about it.

>  - I moved the kernel docs to the header but didn't test if they are
>    picked up when generating docs.  Even if not, there is no better
>    place, is there?

No, that's the proper place, but make sure the docbook source is also
picking up the .h file, I don't know if it currently does.

So, I'll not apply this one just yet.  Can you verify the docbook stuff
at the very least?

thanks,

greg k-h

  reply	other threads:[~2010-06-16 21:02 UTC|newest]

Thread overview: 16+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2010-06-15  8:47 [PATCH 1/2] Driver core: use kmemdup in platform_device_add_resources Uwe Kleine-König
2010-06-15  8:47 ` [PATCH 2/2] Driver core: reduce duplicated code Uwe Kleine-König
2010-06-15  9:05   ` Uwe Kleine-König
2010-06-16 20:53     ` Greg KH [this message]
2010-06-18  7:39       ` Uwe Kleine-König
2010-06-21 13:31         ` [PATCH] ACPI dock: move some functions to .init.text Uwe Kleine-König
2010-10-19  7:13           ` [PATCH RESEND] " Uwe Kleine-König
2010-10-19 15:48             ` Greg KH
2010-10-19 18:03               ` Len Brown
2010-06-21 14:11         ` [PATCH 2/2 v2] Driver core: reduce duplicated code Uwe Kleine-König
2010-06-21 21:38           ` Greg KH
2010-06-22  5:23             ` Uwe Kleine-König
2010-06-28  4:55               ` Eric Miao
2010-06-28  5:16                 ` Uwe Kleine-König
2010-06-28  5:27                   ` Eric Miao
2010-06-21 14:11         ` [PATCH 3/2] Driver core: move platform device creation helpers to .init.text (if MODULE=n) Uwe Kleine-König

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20100616205332.GB15837@kroah.com \
    --to=greg@kroah.com \
    --cc=damm@opensource.se \
    --cc=dtor@mail.ru \
    --cc=eric.y.miao@gmail.com \
    --cc=gregkh@suse.de \
    --cc=lethal@linux-sh.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=netdev@vger.kernel.org \
    --cc=rjw@sisk.pl \
    --cc=u.kleine-koenig@pengutronix.de \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

Powered by JetHome