mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: KOSAKI Motohiro <kosaki.motohiro@jp.fujitsu.com>
To: "Luis Claudio R. Goncalves" <lclaudio@uudg.org>
Cc: kosaki.motohiro@jp.fujitsu.com,
	Minchan Kim <minchan.kim@gmail.com>,
	LKML <linux-kernel@vger.kernel.org>,
	linux-mm <linux-mm@kvack.org>,
	Andrew Morton <akpm@linux-foundation.org>,
	David Rientjes <rientjes@google.com>,
	KAMEZAWA Hiroyuki <kamezawa.hiroyu@jp.fujitsu.com>,
	Oleg Nesterov <oleg@redhat.com>
Subject: Re: [PATCH 9/9] oom: give the dying task a higher priority
Date: Thu, 17 Jun 2010 10:51:35 +0900 (JST)	[thread overview]
Message-ID: <20100617084943.FB45.A69D9226@jp.fujitsu.com> (raw)
In-Reply-To: <20100616195447.GH5009@uudg.org>

> On Thu, Jun 17, 2010 at 12:31:20AM +0900, Minchan Kim wrote:
> | >         /*
> | >          * We give our sacrificial lamb high priority and access to
> | >          * all the memory it needs. That way it should be able to
> | >          * exit() and clear out its resources quickly...
> | >          */
> | >  	p->rt.time_slice = HZ;
> | >  	set_tsk_thread_flag(p, TIF_MEMDIE);
> ...
> | > +	if (rt_task(p)) {
> | > +		p->rt.time_slice = HZ;
> | > +		return;
> 
> I am not sure the code above will have any real effect for an RT task.
> Kosaki-san, was this change motivated by test results or was it just a code
> cleanup? I ask that out of curiosity.

just cleanup.
ok, I remove this dubious code.

> 
> | I have a question from long time ago. 
> | If we change rt.time_slice _without_ setscheduler, is it effective?
> | I mean scheduler pick up the task faster than other normal task?
> 
> $ git log --pretty=oneline -Stime_slice mm/oom_kill.c
> 1da177e4c3f41524e886b7f1b8a0c1fc7321cac2 Linux-2.6.12-rc2
> 
> This code ("time_slice = HZ;") is around for quite a while and
> probably comes from a time where having a big time slice was enough to be
> sure you would be the next on the line. I would say sched_setscheduler is
> indeed necessary.

ok



  reply	other threads:[~2010-06-17  1:56 UTC|newest]

Thread overview: 28+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2010-06-16 11:29 [PATCH 1/9] oom: don't try to kill oom_unkillable child KOSAKI Motohiro
2010-06-16 11:31 ` [PATCH 2/9] oom: rename badness() to oom_badness() KOSAKI Motohiro
2010-06-16 14:46   ` Minchan Kim
2010-06-16 21:40   ` David Rientjes
2010-06-17  1:51     ` KOSAKI Motohiro
2010-06-16 11:32 ` [PATCH 3/9] oom: oom_kill_process() doesn't select kthread child KOSAKI Motohiro
2010-06-16 15:02   ` Minchan Kim
2010-06-17  1:51     ` KOSAKI Motohiro
2010-06-16 11:32 ` [PATCH 4/9] oom: oom_kill_process() need to check p is unkillable KOSAKI Motohiro
2010-06-16 15:07   ` Minchan Kim
2010-06-17  1:51     ` KOSAKI Motohiro
2010-06-16 11:33 ` [PATCH 5/9] oom: make oom_unkillable_task() helper function KOSAKI Motohiro
2010-06-16 15:10   ` Minchan Kim
2010-06-16 11:34 ` [PATCH 6/9] oom: use same_thread_group instead comparing ->mm KOSAKI Motohiro
2010-06-16 12:24   ` Oleg Nesterov
2010-06-17  1:51     ` KOSAKI Motohiro
2010-06-16 15:15   ` Minchan Kim
2010-06-17  1:51     ` KOSAKI Motohiro
2010-06-16 11:34 ` [PATCH 7/9] oom: unify CAP_SYS_RAWIO check into other superuser check KOSAKI Motohiro
2010-06-16 11:35 ` [PATCH 8/9] oom: cleanup has_intersects_mems_allowed() KOSAKI Motohiro
2010-06-16 15:22   ` Minchan Kim
2010-06-16 11:36 ` [PATCH 9/9] oom: give the dying task a higher priority KOSAKI Motohiro
2010-06-16 15:31   ` Minchan Kim
2010-06-16 19:54     ` Luis Claudio R. Goncalves
2010-06-17  1:51       ` KOSAKI Motohiro [this message]
2010-06-17  1:51     ` KOSAKI Motohiro
2010-06-16 14:41 ` [PATCH 1/9] oom: don't try to kill oom_unkillable child Minchan Kim
2010-06-17  1:51   ` KOSAKI Motohiro

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20100617084943.FB45.A69D9226@jp.fujitsu.com \
    --to=kosaki.motohiro@jp.fujitsu.com \
    --cc=akpm@linux-foundation.org \
    --cc=kamezawa.hiroyu@jp.fujitsu.com \
    --cc=lclaudio@uudg.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-mm@kvack.org \
    --cc=minchan.kim@gmail.com \
    --cc=oleg@redhat.com \
    --cc=rientjes@google.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®