mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: "Rafael J. Wysocki" <rjw@sisk.pl>
To: Colin Cross <ccross@android.com>
Cc: Alan Stern <stern@rowland.harvard.edu>,
	linux-kernel@vger.kernel.org,
	linux-pm@lists.linux-foundation.org, Pavel Machek <pavel@ucw.cz>,
	Len Brown <len.brown@intel.com>,
	"Greg Kroah-Hartman" <gregkh@suse.de>,
	Randy Dunlap <randy.dunlap@oracle.com>,
	Andrew Morton <akpm@linux-foundation.org>
Subject: Re: [PATCH] PM: Prevent waiting forever on asynchronous resume after abort
Date: Thu, 2 Sep 2010 23:06:43 +0200	[thread overview]
Message-ID: <201009022306.43470.rjw@sisk.pl> (raw)
In-Reply-To: <AANLkTim7UM80MrwKoAz3hUFrqL2Fbyw6XS=X89PXRc2Q@mail.gmail.com>

On Thursday, September 02, 2010, Colin Cross wrote:
> On Thu, Sep 2, 2010 at 1:45 PM, Alan Stern <stern@rowland.harvard.edu> wrote:
> > On Thu, 2 Sep 2010, Colin Cross wrote:
> >
> >> >> I think it would be better to change device_pm_init() and add a
> >> >> complete_all().
> >> >
> >> > I agree.
> >> That would work, and was my first solution, but it increases the
> >> reliance on the completion variable being left completed between state
> >> transitions, which is undocumented and unnecessary.  It seems more
> >> straightforward to me to only wait on the parent if the parent is
> >> suspended.
> >
> > How about calling complete_all() from within dpm_prepare() as well?
> > Then it will get initialized properly at the beginning of every sleep
> > transition.
> That would work, but I still don't see why it's better.  With either
> of your changes, the power.completion variable is storing state, and
> not just used for notification.  However, the exact meaning of that
> state is unclear, especially during the transition from an aborted
> suspend to resume, and the state is duplicating power.status.  Setting
> it to complete in dpm_prepare is especially confusing, because at that
> point nothing is completed, it hasn't even been started.

It just sets the initial value.  But I agree it would be cleaner to do that
during the initialization.

Thanks,
Rafael

  reply	other threads:[~2010-09-02 21:07 UTC|newest]

Thread overview: 28+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2010-09-02  2:54 Colin Cross
2010-09-02 13:50 ` Alan Stern
2010-09-02 19:46   ` Rafael J. Wysocki
2010-09-02 20:24     ` Colin Cross
2010-09-02 20:30       ` Rafael J. Wysocki
2010-09-02 20:45       ` Alan Stern
2010-09-02 21:01         ` Colin Cross
2010-09-02 21:06           ` Rafael J. Wysocki [this message]
2010-09-02 21:34           ` Alan Stern
2010-09-02 22:45             ` Colin Cross
2010-09-02 23:09               ` Rafael J. Wysocki
2010-09-03  0:14                 ` Colin Cross
2010-09-03  0:35                   ` Rafael J. Wysocki
2010-09-03  1:54                     ` Colin Cross
2010-09-03  2:42                       ` Alan Stern
2010-09-03  4:30                         ` Colin Cross
2010-09-03 14:04                           ` Alan Stern
2010-09-03 16:48                             ` Colin Cross
2010-09-03 17:31                               ` Alan Stern
2010-09-16 20:36                                 ` [PATCH] PM: Fix potential issue with failing asynchronous suspend (was: Re: [PATCH] PM: Prevent waiting ...) Rafael J. Wysocki
2010-09-16 21:00                                   ` Alan Stern
2010-09-16 21:24                                     ` Rafael J. Wysocki
2010-09-02 21:05       ` [PATCH] PM: Prevent waiting forever on asynchronous resume after abort Rafael J. Wysocki
2010-09-02 21:31         ` Colin Cross
2010-09-02 21:40           ` Rafael J. Wysocki
2010-09-02 22:59             ` [PATCH v2] " Colin Cross
2010-09-02 23:25               ` Rafael J. Wysocki
2010-09-02 20:27     ` [PATCH] " Alan Stern

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=201009022306.43470.rjw@sisk.pl \
    --to=rjw@sisk.pl \
    --cc=akpm@linux-foundation.org \
    --cc=ccross@android.com \
    --cc=gregkh@suse.de \
    --cc=len.brown@intel.com \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-pm@lists.linux-foundation.org \
    --cc=pavel@ucw.cz \
    --cc=randy.dunlap@oracle.com \
    --cc=stern@rowland.harvard.edu \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

Powered by JetHome