mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Ingo Molnar <mingo@elte.hu>
To: Peter Zijlstra <peterz@infradead.org>
Cc: Linus Torvalds <torvalds@linux-foundation.org>,
	Thomas Gleixner <tglx@linutronix.de>,
	Andrew Morton <akpm@linux-foundation.org>,
	LKML <linux-kernel@vger.kernel.org>
Subject: Re: [GIT pull] Preparatory patch for semaphore cleanup
Date: Wed, 8 Sep 2010 18:03:26 +0200	[thread overview]
Message-ID: <20100908160326.GA18932@elte.hu> (raw)
In-Reply-To: <1283961504.23762.34.camel@laptop>


* Peter Zijlstra <peterz@infradead.org> wrote:

> On Wed, 2010-09-08 at 17:56 +0200, Ingo Molnar wrote:
> > * Peter Zijlstra <peterz@infradead.org> wrote:
> > 
> > > On Wed, 2010-09-08 at 07:54 -0700, Linus Torvalds wrote:
> > > > On Wed, Sep 8, 2010 at 6:11 AM, Thomas Gleixner <tglx@linutronix.de> wrote:
> > > > >
> > > > > This patch just provides the DEFINE_SEMAPHORE macro which is required
> > > > > for the various subsystem cleanups I sent out, so we can finally get
> > > > > rid of init_MUTEX[_LOCKED] in 2.6.37.
> > > > 
> > > > Why is it called DEFINE_SEMAPHORE(), when two lines later the we have
> > > > DECLARE_MUTEX()?
> > > > 
> > > > IOW, the whole DEFINE vs DECLARE thing seems confused. I'm not saying
> > > > one is better than the other (maybe "define" is), but the mixing of
> > > > names is worse than either, I feel..
> > > 
> > > The rest of the series, that Thomas didn't include in this pull, removes
> > > all the DECLARE_MUTEX() users. So its temporary awkward-ness.
> > 
> > and DEFINE_MUTEX() is needed upstream so that we can spread those 
> 
> s/DEFINE_MUTEX/DEFINE_SEMAPHORE/

Heh, i was demonstrating Linus's point ;-)

Thanks,

	Ingo

  reply	other threads:[~2010-09-08 16:03 UTC|newest]

Thread overview: 7+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2010-09-08 13:11 Thomas Gleixner
2010-09-08 14:54 ` Linus Torvalds
2010-09-08 14:59   ` Peter Zijlstra
2010-09-08 15:56     ` Ingo Molnar
2010-09-08 15:58       ` Peter Zijlstra
2010-09-08 16:03         ` Ingo Molnar [this message]
2010-09-08 15:05   ` Thomas Gleixner

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20100908160326.GA18932@elte.hu \
    --to=mingo@elte.hu \
    --cc=akpm@linux-foundation.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=peterz@infradead.org \
    --cc=tglx@linutronix.de \
    --cc=torvalds@linux-foundation.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®