From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1755617Ab0ITHym (ORCPT ); Mon, 20 Sep 2010 03:54:42 -0400 Received: from e37.co.us.ibm.com ([32.97.110.158]:51790 "EHLO e37.co.us.ibm.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1755601Ab0ITHyj (ORCPT ); Mon, 20 Sep 2010 03:54:39 -0400 Date: Mon, 20 Sep 2010 13:24:33 +0530 From: Balbir Singh To: Hiroyuki Kamezawa Cc: KAMEZAWA Hiroyuki , "linux-mm@kvack.org" , "linux-kernel@vger.kernel.org" , "nishimura@mxp.nes.nec.co.jp" , "akpm@linux-foundation.org" Subject: Re: [PATCH][-mm] memcg : memory cgroup cpu hotplug support update. Message-ID: <20100920075433.GB6676@balbir.in.ibm.com> Reply-To: balbir@linux.vnet.ibm.com References: <20100916144618.852b7e9a.kamezawa.hiroyu@jp.fujitsu.com> <20100916062159.GF22371@balbir.in.ibm.com> <20100916152204.6c457936.kamezawa.hiroyu@jp.fujitsu.com> <20100916161727.04a1f905.kamezawa.hiroyu@jp.fujitsu.com> <20100917063537.GA4534@balbir.in.ibm.com> MIME-Version: 1.0 Content-Type: text/plain; charset=iso-8859-1 Content-Disposition: inline Content-Transfer-Encoding: 8bit In-Reply-To: User-Agent: Mutt/1.5.20 (2009-12-10) Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org * Hiroyuki Kamezawa [2010-09-17 20:49:09]: > 2010/9/17 Balbir Singh : > > * KAMEZAWA Hiroyuki [2010-09-16 16:17:27]: > > > >> On Thu, 16 Sep 2010 15:22:04 +0900 > >> KAMEZAWA Hiroyuki wrote: > >> > >> > This naming is from mem_cgroup_walk_tree(). Now we have > >> > > >> >   mem_cgroup_walk_tree(); > >> >   mem_cgroup_walk_all(); > >> > > >> > Rename both ? But it should be in separated patch. > >> > > >> > >> Considering a bit ...but.. > >> > >> #define for_each_mem_cgroup(mem) \ > >>       for (mem = mem_cgroup_get_first(); \ > >>            mem; \ > >>            mem = mem_cgroup_get_next(mem);) \ > >> > >> seems to need some helper functions. I'll consider about this clean up > >> but it requires some amount of patch because css_get()/css_put()/rcu...etc.. > >> are problematic. > >> > > > > Why does this need to be a macro (I know we use this for lists and > > other places), assuming for now we don't use the iterator pattern, we > > can rename mem_cgroup_walk_all() to for_each_mem_cgroup(). > > > > When I see for_each in the kernel source, I expect iterator and macro. > When I see "walk" in the kernel source, I expect callback and visit function. > I understand that is the convention we used thus far. When I see for_each for walk, I presume iterators, doesn't matter if we have a call back or not. I'll leave the decision to you. -- Three Cheers, Balbir