mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Grant Likely <grant.likely@secretlab.ca>
To: David Brownell <david-b@pacbell.net>
Cc: davinci-linux-open-source@linux.davincidsp.com,
	spi-devel-general@lists.sourceforge.net,
	broonie@opensource.wolfsonmicro.com, lrg@slimlogic.co.uk,
	linux-arm-kernel@lists.infradead.org,
	linux-kernel@vger.kernel.org, rpurdie@rpsys.net,
	Cyril Chemparathy <cyril@ti.com>
Subject: Re: [PATCH v4 08/12] gpio: add ti-ssp gpio driver
Date: Tue, 9 Nov 2010 21:45:30 -0700	[thread overview]
Message-ID: <20101110044530.GB4110@angua.secretlab.ca> (raw)
In-Reply-To: <956998.65651.qm@web180302.mail.gq1.yahoo.com>

On Tue, Nov 02, 2010 at 07:15:16PM -0700, David Brownell wrote:
> 
> 
> --- On Tue, 10/26/10, Cyril Chemparathy <cyril@ti.com> wrote:
> 
> > From: Cyril Chemparathy <cyril@ti.com>
> > Subject: [PATCH v4 08/12] gpio: add ti-ssp gpio driver
> 
> On the assumptions you've tested this *AND* will
> resubmit with the previously-requested change of
> removing all references to non-existent
> "virtual"ness in the driver ... I'll likely
> add my ack to that resubmitted version
> 
> Also, chip2gpio seems an excessively generic name;
> maybe chip2_ti_ssp_gpio or somesuch?
> 
> I'd still be happier seeing this "stack" packaged
> as a hardware library called by various drivers
> (like GPIO, SPI, etc) rather than a core driver
> that's called by other drivers.  That seems like
> a better structure for various vendors' "SSP"
> hardware (multifunction serial interface logic)
> since most function drivers just need to poke
> the registers a bit differently, and don't have
> much to share with a "core driver" beyond a few
> setup routines (if that).

I thought the point of this device was that a single device hosted a
pair of multi-function serial interfaces, with each implementing a
separate function.  If so, then it makes sense for the base driver to
register child devices of the appropriate kinds.

g.


  parent reply	other threads:[~2010-11-10  4:45 UTC|newest]

Thread overview: 24+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2010-10-26 20:18 [PATCH v4 00/12] tnetv107x ssp driver stack Cyril Chemparathy
2010-10-26 20:18 ` [PATCH v4 01/12] misc: add driver for sequencer serial port Cyril Chemparathy
2010-10-28 15:49   ` Linus Walleij
2010-10-28 16:09     ` Cyril Chemparathy
2010-10-28 18:14       ` Linus Walleij
2010-10-26 20:18 ` [PATCH v4 02/12] davinci: add tnetv107x ssp platform device Cyril Chemparathy
2010-10-26 20:18 ` [PATCH v4 03/12] davinci: add ssp config for tnetv107x evm board Cyril Chemparathy
2010-10-26 20:18 ` [PATCH v4 04/12] spi: add ti-ssp spi master driver Cyril Chemparathy
2010-10-26 20:18 ` [PATCH v4 05/12] davinci: add spi devices on tnetv107x evm Cyril Chemparathy
2010-10-26 20:18 ` [PATCH v4 06/12] regulator: add driver for tps6524x regulator Cyril Chemparathy
2010-10-26 20:18 ` [PATCH v4 07/12] davinci: add tnetv107x evm regulators Cyril Chemparathy
2010-10-26 20:18 ` [PATCH v4 08/12] gpio: add ti-ssp gpio driver Cyril Chemparathy
2010-11-03  2:15   ` David Brownell
2010-11-03 10:18     ` Linus Walleij
2010-11-03 12:35       ` David Brownell
2010-11-03 16:24         ` Linus Walleij
2010-11-10  4:45     ` Grant Likely [this message]
2010-11-10  6:16       ` David Brownell
2010-11-10  6:23         ` Grant Likely
2010-11-10 14:34           ` Cyril Chemparathy
2010-10-26 20:18 ` [PATCH v4 09/12] davinci: add tnetv107x evm ti-ssp gpio device Cyril Chemparathy
2010-10-26 20:18 ` [PATCH v4 10/12] backlight: add support for tps6116x controller Cyril Chemparathy
2010-10-26 20:18 ` [PATCH v4 11/12] davinci: add tnetv107x evm backlight device Cyril Chemparathy
2010-10-26 20:18 ` [PATCH v4 12/12] davinci: add tnetv107x evm i2c eeprom device Cyril Chemparathy

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20101110044530.GB4110@angua.secretlab.ca \
    --to=grant.likely@secretlab.ca \
    --cc=broonie@opensource.wolfsonmicro.com \
    --cc=cyril@ti.com \
    --cc=david-b@pacbell.net \
    --cc=davinci-linux-open-source@linux.davincidsp.com \
    --cc=linux-arm-kernel@lists.infradead.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=lrg@slimlogic.co.uk \
    --cc=rpurdie@rpsys.net \
    --cc=spi-devel-general@lists.sourceforge.net \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®