mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Mathieu Desnoyers <mathieu.desnoyers@efficios.com>
To: Steven Rostedt <rostedt@goodmis.org>
Cc: Peter Zijlstra <peterz@infradead.org>,
	linux-kernel@vger.kernel.org, Ingo Molnar <mingo@elte.hu>,
	Andrew Morton <akpm@linux-foundation.org>,
	Thomas Gleixner <tglx@linutronix.de>,
	Frederic Weisbecker <fweisbec@gmail.com>,
	Darren Hart <dvhart@linux.intel.com>,
	Linus Torvalds <torvalds@linux-foundation.org>,
	"jason.wessel" <jason.wessel@windriver.com>,
	"Ted Ts'o" <tytso@mit.edu>
Subject: Re: [RFC][PATCH 0/2] tracing: Have trace_printk()s in the events/ directory
Date: Thu, 18 Nov 2010 08:03:24 -0500	[thread overview]
Message-ID: <20101118130324.GB3741@Krystal> (raw)
In-Reply-To: <1290082454.30543.98.camel@gandalf.stny.rr.com>

* Steven Rostedt (rostedt@goodmis.org) wrote:
> On Thu, 2010-11-18 at 07:06 -0500, Mathieu Desnoyers wrote:
> > * Steven Rostedt (rostedt@goodmis.org) wrote:
> > > On Thu, 2010-11-18 at 11:41 +0100, Peter Zijlstra wrote:
> > > > On Wed, 2010-11-17 at 22:58 -0500, Steven Rostedt wrote:
> > > > > For example, I added a trace_printk() in kernel/sched.c at line 2180
> > > > > and it creates:
> > > > > 
> > > > > # ls /debug/tracing/events/printk/kernel/sched.c/2180/
> > > > > enable  format
> > > > > 
> > > > > The format is the printk format:
> > > > > 
> > > > > # cat /debug/tracing/events/printk/kernel/sched.c/2180/format 
> > > > > "migrate task %s:%d"
> > > > 
> > > > *groan*, so you're creating a tracepoint per instance?
> > > > 
> > > > That's going to be massive pain for perf.. I really don't see the point
> > > > in splitting all that out.
> > > 
> > > a) The file directory was what was asked about in the referenced email.
> > > b) This is just an example of a way to display it to the user, which
> > > seems to be very intuitive.
> > > c) Perf can implement the details anyway it wants. It can make a single
> > > tracepoint callback and have the enabling of the points as a special
> > > filter.
> > > d) This was just an RFC that Frederic asked if I would do. I thought it
> > > would be a fun challenge and did it. Let it bit rot in hell for all I
> > > care, I wasn't taking it any further anyway.
> > 
> > Hi Steven,
> > 
> > The LTTng tree still keeps the "trace_mark()" kernel markers, which are
> > very very similar to ftrace_printk(). I'd be happy to combine the two
> > eventually. This one file per line approach seems very good -- rather than
> > explicitely naming each instance, as I did in trace_mark(), you end up
> > automatically naming them by file/line number.
> > 
> > How does this behave from within static inlines called multiple times and
> > unrolled loops ?
> 
> Actually you mean macros:
> 
> You'll get a 2181-1, 2181-2, 2181-3, etc.

This is neat, great ! :)

> 
> Although a trace_printk() in a header static inline may be interesting.

Yep, food for thoughts. ;-)

Thank you !

Mathieu

-- 
Mathieu Desnoyers
Operating System Efficiency R&D Consultant
EfficiOS Inc.
http://www.efficios.com

  reply	other threads:[~2010-11-18 13:03 UTC|newest]

Thread overview: 19+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2010-11-18  3:58 Steven Rostedt
2010-11-18  3:58 ` [RFC][PATCH 1/2] [PATCH 1/2] tracing: Rename trace_printk to ftrace_printk Steven Rostedt
2010-11-18  3:58 ` [RFC][PATCH 2/2] [PATCH 2/2] tracing: Make event based trace_printk() Steven Rostedt
2010-11-18  4:19   ` Steven Rostedt
2010-11-18  5:50   ` Lai Jiangshan
2010-11-18 12:22     ` Steven Rostedt
2010-11-18 11:58   ` Mathieu Desnoyers
2010-11-18 12:14     ` Steven Rostedt
2010-11-18 10:41 ` [RFC][PATCH 0/2] tracing: Have trace_printk()s in the events/ directory Peter Zijlstra
2010-11-18 11:53   ` Steven Rostedt
2010-11-18 12:06     ` Mathieu Desnoyers
2010-11-18 12:14       ` Steven Rostedt
2010-11-18 13:03         ` Mathieu Desnoyers [this message]
2010-11-18 12:53   ` Frederic Weisbecker
2010-11-18 13:06     ` Steven Rostedt
2010-11-18 14:02       ` Frederic Weisbecker
2010-11-18 13:21     ` Peter Zijlstra
2010-11-18 13:36       ` Frederic Weisbecker
2010-11-18 12:39 ` Frederic Weisbecker

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20101118130324.GB3741@Krystal \
    --to=mathieu.desnoyers@efficios.com \
    --cc=akpm@linux-foundation.org \
    --cc=dvhart@linux.intel.com \
    --cc=fweisbec@gmail.com \
    --cc=jason.wessel@windriver.com \
    --cc=linux-kernel@vger.kernel.org \
    --cc=mingo@elte.hu \
    --cc=peterz@infradead.org \
    --cc=rostedt@goodmis.org \
    --cc=tglx@linutronix.de \
    --cc=torvalds@linux-foundation.org \
    --cc=tytso@mit.edu \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®