mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Marcelo Tosatti <mtosatti@redhat.com>
To: Xiao Guangrong <xiaoguangrong@cn.fujitsu.com>
Cc: Avi Kivity <avi@redhat.com>, LKML <linux-kernel@vger.kernel.org>,
	KVM <kvm@vger.kernel.org>
Subject: Re: [PATCH v2 5/6] KVM: MMU: remove 'clear_unsync' parameter
Date: Thu, 18 Nov 2010 13:43:49 -0200	[thread overview]
Message-ID: <20101118154349.GF14327@amt.cnet> (raw)
In-Reply-To: <4CE4D8C9.90302@cn.fujitsu.com>

On Thu, Nov 18, 2010 at 03:42:01PM +0800, Xiao Guangrong wrote:
> On 11/18/2010 12:49 AM, Marcelo Tosatti wrote:
> 			    bool clear_unsync)
> >> +static int FNAME(sync_page)(struct kvm_vcpu *vcpu, struct kvm_mmu_page *sp)
> >>  {
> >>  	int i, offset, nr_present;
> >>  	bool host_writable;
> >> @@ -781,7 +780,7 @@ static int FNAME(sync_page)(struct kvm_vcpu *vcpu, struct kvm_mmu_page *sp,
> >>  			u64 nonpresent;
> >>  
> >>  			if (rsvd_bits_set || is_present_gpte(gpte) ||
> >> -			      !clear_unsync)
> >> +			      sp->unsync)
> >>  				nonpresent = shadow_trap_nonpresent_pte;
> >>  			else
> >>  				nonpresent = shadow_notrap_nonpresent_pte;
> > 
> > Its better to keep this explicit as a parameter. 
> > 
> 
> But after patch 6 (KVM: MMU: cleanup update_pte, pte_prefetch and sync_page functions),
> this parameter is not used anymore... i don't have strong opinion on it :-)

On a second thought, using sp->unsync is fine.

  reply	other threads:[~2010-11-18 16:16 UTC|newest]

Thread overview: 22+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2010-11-17  4:10 [PATCH v2 1/6] KVM: MMU: fix forgot flush vcpu tlbs Xiao Guangrong
2010-11-17  4:10 ` [PATCH v2 2/6] KVM: MMU: don't drop spte if overwrite it from W to RO Xiao Guangrong
2010-11-17 15:42   ` Marcelo Tosatti
2010-11-17 15:57     ` Avi Kivity
2010-11-18  7:12       ` Xiao Guangrong
2010-11-18 15:32         ` Marcelo Tosatti
2010-11-18 16:41           ` Avi Kivity
2010-11-17  4:11 ` [PATCH v2 3/6] KVM: MMU: don't mark spte notrap if reserved bit set Xiao Guangrong
2010-11-17 15:56   ` Marcelo Tosatti
2010-11-17  4:12 ` [PATCH v2 4/6] KVM: MMU: rename 'reset_host_protection' to 'host_writable' Xiao Guangrong
2010-11-17 15:58   ` Marcelo Tosatti
2010-11-17  4:13 ` [PATCH v2 5/6] KVM: MMU: remove 'clear_unsync' parameter Xiao Guangrong
2010-11-17 16:49   ` Marcelo Tosatti
2010-11-18  7:42     ` Xiao Guangrong
2010-11-18 15:43       ` Marcelo Tosatti [this message]
2010-11-17  4:13 ` [PATCH v2 6/6] KVM: MMU: cleanup update_pte, pte_prefetch and sync_page functions Xiao Guangrong
2010-11-17 16:55   ` Marcelo Tosatti
2010-11-17 15:29 ` [PATCH v2 1/6] KVM: MMU: fix forgot flush vcpu tlbs Marcelo Tosatti
2010-11-17 16:26   ` Avi Kivity
2010-11-17 17:36     ` Marcelo Tosatti
2010-11-18  7:17       ` Xiao Guangrong
2010-11-18  9:32         ` Avi Kivity

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20101118154349.GF14327@amt.cnet \
    --to=mtosatti@redhat.com \
    --cc=avi@redhat.com \
    --cc=kvm@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=xiaoguangrong@cn.fujitsu.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

Powered by JetHome