mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Sam Ravnborg <sam@ravnborg.org>
To: Andrew Morton <akpm@linux-foundation.org>
Cc: Sedat Dilek <sedat.dilek@googlemail.com>,
	dilinger@queued.net, sameo@linux.intel.com, tj@kernel.org,
	joe@perches.com, linux-kernel@vger.kernel.org,
	Sedat Dilek <sedat.dilek@gmail.com>
Subject: Re: [PATCH] misc/cs5535: Fix section mismatch derived from cs5535_mfgpt_drv variable
Date: Mon, 3 Jan 2011 20:51:31 +0100	[thread overview]
Message-ID: <20110103195131.GA9568@merkur.ravnborg.org> (raw)
In-Reply-To: <20110103114310.8b06e73e.akpm@linux-foundation.org>

On Mon, Jan 03, 2011 at 11:43:10AM -0800, Andrew Morton wrote:
> On Mon,  3 Jan 2011 03:51:28 +0100
> Sedat Dilek <sedat.dilek@googlemail.com> wrote:
> 
> > >From my build.log:
> > 
> > WARNING: drivers/misc/cs5535-mfgpt.o(.data+0x0): Section mismatch in reference from the variable cs5535_mfgpt_drv to the function .devinit.text:cs5535_mfgpt_probe()
> > The variable cs5535_mfgpt_drv references
> > the function __devinit cs5535_mfgpt_probe()
> > If the reference is valid then annotate the
> > variable with __init* or __refdata (see linux/init.h) or name the variable:
> > *driver, *_template, *_timer, *_sht, *_ops, *_probe, *_probe_one, *_console,
> 
> Confused.  cs5535_mfgpt_probe() _does_ have a name of the form
> "*_probe", so why did it warn?

The varibale need to follow the naming scheme.
In this case the function was named *_probe - which has no significance
in the section mismatch checks.

> > variable with __init* or __refdata (see linux/init.h) or name the variable:
    ^^^^^^^^                                                          ^^^^^^^^^ 

	Sam

  reply	other threads:[~2011-01-03 19:51 UTC|newest]

Thread overview: 9+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2011-01-03  2:51 Sedat Dilek
2011-01-03  9:52 ` Andres Salomon
2011-01-03 10:04   ` Sedat Dilek
2011-01-03 19:43 ` Andrew Morton
2011-01-03 19:51   ` Sam Ravnborg [this message]
2011-01-03 20:34     ` Andres Salomon
2011-01-03 20:50       ` Sam Ravnborg
2011-01-03 21:14         ` Andres Salomon
2011-01-04  5:59           ` Sam Ravnborg

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20110103195131.GA9568@merkur.ravnborg.org \
    --to=sam@ravnborg.org \
    --cc=akpm@linux-foundation.org \
    --cc=dilinger@queued.net \
    --cc=joe@perches.com \
    --cc=linux-kernel@vger.kernel.org \
    --cc=sameo@linux.intel.com \
    --cc=sedat.dilek@gmail.com \
    --cc=sedat.dilek@googlemail.com \
    --cc=tj@kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®