From: Tejun Heo <tj@kernel.org>
To: Yinghai Lu <yinghai@kernel.org>
Cc: Thomas Gleixner <tglx@linutronix.de>, Ingo Molnar <mingo@elte.hu>,
"H. Peter Anvin" <hpa@zytor.com>,
David Rientjes <rientjes@google.com>,
"linux-kernel@vger.kernel.org" <linux-kernel@vger.kernel.org>
Subject: Re: [PATCH] x86, numa: refactoring numa_register_memblks
Date: Thu, 17 Feb 2011 00:03:40 +0100 [thread overview]
Message-ID: <20110216230340.GF29600@atj.dyndns.org> (raw)
In-Reply-To: <4D5C554E.7050701@kernel.org>
On Wed, Feb 16, 2011 at 02:53:02PM -0800, Yinghai Lu wrote:
> > Sorry, nack. This squarely falls in the realm of bikeshedding and I
> > plan on collapsing init_memory_mapping_high() into the register
> > function.
>
> no. init_memory_mapping_high now it is with early_node_map[], aka it
> is e820 and srat table overlapping one.
Hmmm... okay, I'll think more about it but currently it looks silly.
It isn't necessary for !NUMA and is done in rather convoluted way in
NUMA. The name is misleading too. There's nothing like mapped high
memory. Maybe it would be better to use suffix like _above_4g. At
any rate, I don't really see the point of moving those functions
calls.
The way I see it is that these things are inherently subjective. When
you're writing or updating the part, it's natural to follow your own
preference. When reviewing or working on other's code, trying to
enforce all those subjective details doesn't really help anyone. Push
the ones with technical advantages; otherwise, just let it go.
Thanks.
--
tejun
next prev parent reply other threads:[~2011-02-16 23:03 UTC|newest]
Thread overview: 20+ messages / expand[flat|nested] mbox.gz Atom feed top
2011-02-16 20:56 [PATCH] x86, numa: exit early on numa_reset_distance() Yinghai Lu
2011-02-16 20:57 ` [PATCH] x86, numa: seperate alloc_numa_distance from numa_reset_distance Yinghai Lu
2011-02-16 21:44 ` Cyrill Gorcunov
2011-02-16 22:29 ` Yinghai Lu
2011-02-16 22:47 ` Cyrill Gorcunov
2011-02-16 22:51 ` Tejun Heo
2011-02-16 20:58 ` [PATCH] x86, numa: refactoring numa_register_memblks Yinghai Lu
2011-02-16 22:43 ` Tejun Heo
2011-02-16 22:53 ` Yinghai Lu
2011-02-16 23:03 ` Tejun Heo [this message]
2011-02-16 22:30 ` [PATCH] x86, numa: put dummy_numa_init in init section Yinghai Lu
2011-02-16 22:44 ` Tejun Heo
[not found] ` <20110217130526.GB27911@elte.hu>
[not found] ` <20110217132435.GV19830@htj.dyndns.org>
[not found] ` <20110217135628.GB7018@elte.hu>
[not found] ` <4D5D48DA.6020908@kernel.org>
[not found] ` <20110217161649.GD14168@elte.hu>
2011-02-24 7:21 ` [PATCH -v2] x86: Rename e820_table_* to pgt_buf_* Yinghai Lu
2011-02-24 13:59 ` [PATCH] " Tejun Heo
2011-02-16 22:31 ` [PATCH] x86, numa: cleanup x86_acpi_numa_init() Yinghai Lu
2011-02-16 22:49 ` Tejun Heo
2011-02-16 22:55 ` Yinghai Lu
2011-02-16 22:39 ` [PATCH] x86, numa: exit early on numa_reset_distance() Tejun Heo
2011-02-16 23:08 ` Yinghai Lu
2011-02-16 23:15 ` Tejun Heo
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20110216230340.GF29600@atj.dyndns.org \
--to=tj@kernel.org \
--cc=hpa@zytor.com \
--cc=linux-kernel@vger.kernel.org \
--cc=mingo@elte.hu \
--cc=rientjes@google.com \
--cc=tglx@linutronix.de \
--cc=yinghai@kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®