From: Grant Likely <grant.likely@secretlab.ca>
To: viresh kumar <viresh.kumar@st.com>
Cc: "jgarzik@pobox.com" <jgarzik@pobox.com>,
"linux-ide@vger.kernel.org" <linux-ide@vger.kernel.org>,
"linux-kernel@vger.kernel.org" <linux-kernel@vger.kernel.org>,
Armando VISCONTI <armando.visconti@st.com>,
Shiraz HASHIM <shiraz.hashim@st.com>,
rsarmah@appliedmicro.com, Stephen Rothwell <sfr@canb.auug.org.au>
Subject: Re: drivers/ata/sata_dwc_460ex.c: Do we still need "struct of_device_id sata_dwc_match"
Date: Tue, 7 Jun 2011 09:03:57 -0600 [thread overview]
Message-ID: <20110607150357.GG13072@ponder.secretlab.ca> (raw)
In-Reply-To: <4DEE0313.8090002@st.com>
On Tue, Jun 07, 2011 at 04:23:07PM +0530, viresh kumar wrote:
>
> Hello,
>
> sata_dwc is also present on SPEAr SoC from ST, so i am removing dependency of this
> driver from 460ex and renaming it to sata_dwc.c.
>
> While doing that, i saw following:
>
> static const struct of_device_id sata_dwc_match[] = {
> { .compatible = "amcc,sata-460ex", },
> {}
> };
> MODULE_DEVICE_TABLE(of, sata_dwc_match);
>
>
> I don't know if this is still useful or not with platform_device, as it was with
> of_platform_*.
>
> Should i remove it completely? or should i just rewrite following as:
>
> static const struct of_device_id sata_dwc_match[] = {
> { .compatible = "amcc,sata_dwc", },
> {}
> };
> MODULE_DEVICE_TABLE(of, sata_dwc_match);
No, don't remove it and don't remove the "amcc,sata-460ex" string.
The compatible property is intended to identify the exact hardware,
and removing existing strings will break deployed boards. However, it
is fine to add new strings to the match table.
>
> For this i will also update: arch/powerpc/boot/dts/canyonlands.dts
>
> SATA0: sata@bffd1000 {
> compatible = "amcc,sata-460ex";
> reg = <4 0xbffd1000 0x800 4 0xbffd0800 0x400>;
> interrupt-parent = <&UIC3>;
> interrupts = <0x0 0x4 /* SATA */
> 0x5 0x4>; /* AHBDMA */
> };
>
> Thanks for your replies.
>
> --
> viresh
prev parent reply other threads:[~2011-06-07 15:04 UTC|newest]
Thread overview: 2+ messages / expand[flat|nested] mbox.gz Atom feed top
2011-06-07 10:53 viresh kumar
2011-06-07 15:03 ` Grant Likely [this message]
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20110607150357.GG13072@ponder.secretlab.ca \
--to=grant.likely@secretlab.ca \
--cc=armando.visconti@st.com \
--cc=jgarzik@pobox.com \
--cc=linux-ide@vger.kernel.org \
--cc=linux-kernel@vger.kernel.org \
--cc=rsarmah@appliedmicro.com \
--cc=sfr@canb.auug.org.au \
--cc=shiraz.hashim@st.com \
--cc=viresh.kumar@st.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®