From: Felipe Balbi <balbi@ti.com>
To: Alan Stern <stern@rowland.harvard.edu>
Cc: Felipe Balbi <balbi@ti.com>,
Michal Nazarewicz <mnazarewicz@google.com>,
Sebastian Andrzej Siewior <bigeasy@linutronix.de>,
Yang Rui Rui <ruirui.r.yang@tieto.com>,
Dave Young <hidave.darkstar@gmail.com>,
linux-usb@vger.kernel.org, linux-kernel@vger.kernel.org
Subject: Re: [PATCHv3 2/4] usb: gadget: replace "is_dualspeed" with "max_speed"
Date: Tue, 23 Aug 2011 20:21:12 +0300 [thread overview]
Message-ID: <20110823172111.GD10996@legolas.emea.dhcp.ti.com> (raw)
In-Reply-To: <Pine.LNX.4.44L0.1108231141400.2069-100000@iolanthe.rowland.org>
[-- Attachment #1: Type: text/plain, Size: 823 bytes --]
Hi,
On Tue, Aug 23, 2011 at 11:43:44AM -0400, Alan Stern wrote:
> > if they are both part of the of the same configuration, full speed.
> > Otherwise Audio won't work. If they are part of different
> > configurations, then maximum_speed will be defined by the chosen config,
> > no ?
>
> No. The speed has to be chosen first, when the gadget connects to the
> host. The config isn't chosen until later, after the host retrieves
> the various descriptors and decides among them.
true
> > I stand with the fact that if they are part of the same configuration,
> > there's no way around it, storage will have to come down to full speed.
> > Unless I'm missing something.
>
> What if they are in different configurations?
then you use the fastest speed between both configurations?
--
balbi
[-- Attachment #2: Digital signature --]
[-- Type: application/pgp-signature, Size: 490 bytes --]
next prev parent reply other threads:[~2011-08-23 17:21 UTC|newest]
Thread overview: 70+ messages / expand[flat|nested] mbox.gz Atom feed top
[not found] <4E4B9D9C.2010607@linutronix.de>
2011-08-17 13:03 ` [PATCH] usb: gadget: get rid of USB_GADGET_DUALSPEED and USB_GADGET_SUPERSPEED Michal Nazarewicz
2011-08-17 14:20 ` Alan Stern
2011-08-17 14:27 ` Michal Nazarewicz
2011-08-17 14:47 ` Alan Stern
2011-08-17 15:07 ` Michal Nazarewicz
2011-08-17 16:25 ` Alan Stern
2011-08-17 14:36 ` Sergei Shtylyov
2011-08-17 14:45 ` Michal Nazarewicz
2011-08-17 15:33 ` [PATCHv2] " Michal Nazarewicz
2011-08-17 21:09 ` Alan Stern
2011-08-18 13:19 ` Michal Nazarewicz
2011-08-18 14:59 ` Alan Stern
2011-08-18 17:05 ` Michal Nazarewicz
2011-08-18 17:27 ` Alan Stern
2011-08-18 20:13 ` Michal Nazarewicz
2011-08-18 20:30 ` Alan Stern
2011-08-18 20:44 ` Michal Nazarewicz
2011-08-19 10:53 ` Michal Nazarewicz
2011-08-19 11:13 ` Sebastian Andrzej Siewior
2011-08-19 12:14 ` Michal Nazarewicz
2011-08-19 14:29 ` Alan Stern
2011-08-19 14:38 ` Michal Nazarewicz
2011-08-19 14:57 ` Alan Stern
2011-08-19 2:02 ` Yang Rui Rui
2011-08-19 12:17 ` Michal Nazarewicz
2011-08-18 3:01 ` Yang Rui Rui
2011-08-18 11:57 ` Michal Nazarewicz
2011-08-18 13:24 ` Dave Young
2011-08-18 13:41 ` Michal Nazarewicz
2011-08-19 22:32 ` [PATCHv3 0/4] Figuring out speed refactorisation Michal Nazarewicz
2011-08-19 22:32 ` [PATCHv3 1/4] usb: Provide usb_device_speed_name() function Michal Nazarewicz
2011-08-19 23:15 ` Felipe Balbi
2011-08-22 14:53 ` Michal Nazarewicz
2011-08-19 22:33 ` [PATCHv3 2/4] usb: gadget: replace "is_dualspeed" with "max_speed" Michal Nazarewicz
2011-08-19 23:28 ` Felipe Balbi
2011-08-23 13:48 ` Michal Nazarewicz
2011-08-23 13:58 ` Felipe Balbi
2011-08-23 14:15 ` Michal Nazarewicz
2011-08-23 14:37 ` Alan Stern
2011-08-23 14:58 ` Felipe Balbi
2011-08-23 15:07 ` Michal Nazarewicz
2011-08-23 15:11 ` Felipe Balbi
2011-08-23 15:26 ` Michal Nazarewicz
2011-08-23 17:19 ` Felipe Balbi
2011-08-23 18:44 ` Michal Nazarewicz
2011-08-23 15:43 ` Alan Stern
2011-08-23 17:21 ` Felipe Balbi [this message]
2011-08-23 18:00 ` Alan Stern
2011-08-23 19:05 ` Michal Nazarewicz
2011-08-23 20:49 ` Alan Stern
2011-08-24 8:56 ` Felipe Balbi
2011-08-24 13:10 ` Michal Nazarewicz
2011-08-24 14:31 ` Alan Stern
2011-08-24 14:53 ` Michal Nazarewicz
2011-08-24 15:15 ` Alan Stern
2011-08-24 15:25 ` Michal Nazarewicz
2011-08-24 23:04 ` Felipe Balbi
2011-08-25 12:46 ` Michal Nazarewicz
2011-08-25 12:53 ` Felipe Balbi
2011-08-24 22:57 ` Felipe Balbi
2011-08-23 15:05 ` Felipe Balbi
2011-08-23 15:30 ` Michal Nazarewicz
2011-08-19 22:33 ` [PATCHv3 3/4] usb: gadget: rename usb_gadget_driver::speed to max_speed Michal Nazarewicz
2011-08-19 23:31 ` Felipe Balbi
2011-08-20 2:34 ` Alan Stern
2011-08-22 10:42 ` Felipe Balbi
2011-08-19 22:33 ` [PATCHv3 4/4] usb: gadget: get rid of USB_GADGET_{DUAL,SUPER}SPEED Michal Nazarewicz
2011-08-20 13:41 ` Alan Stern
2011-08-22 14:51 ` Michal Nazarewicz
2011-08-22 15:03 ` Alan Stern
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20110823172111.GD10996@legolas.emea.dhcp.ti.com \
--to=balbi@ti.com \
--cc=bigeasy@linutronix.de \
--cc=hidave.darkstar@gmail.com \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-usb@vger.kernel.org \
--cc=mnazarewicz@google.com \
--cc=ruirui.r.yang@tieto.com \
--cc=stern@rowland.harvard.edu \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®