mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Manohar Vanga <manohar.vanga@cern.ch>
To: Martyn Welch <martyn.welch@ge.com>
Cc: <gregkh@suse.de>, <cota@braap.org>, <devel@driverdev.osuosl.org>,
	<linux-kernel@vger.kernel.org>
Subject: Re: [PATCH 2/3] staging: vme: add struct vme_dev for VME devices
Date: Mon, 26 Sep 2011 16:06:55 +0200	[thread overview]
Message-ID: <20110926140655.GA16310@becoht-mvanga> (raw)
In-Reply-To: <4E609BAF.2020102@ge.com>

Hi Martyn,

Apologies for the delay, I was on vacation recently.

> I think we can probably merge vme_device_id and vme_dev.
> 
> Since we have a pointer to the vme_bridge, the bus number in vme_device_id is
> kinda superfluous.
> 
> The direction we are heading in makes the slot number far less important, in
> some ways it becomes more of an optional information field (in pre-vme64 racks
> we probably won't know which slot the device we are bound to is in anyway).
> Basically moving from a binding mechanism like PCI to a binding mechanism
> closer to ISA, which matches the (widely used, more historic subset) of
> capabilites of the VME bus. I think we can just move the slot number to
> vme_dev and do away with vme_device_id entirely.

I agree with this. I have, however, done this in a separate patch for clarity.
(I have resent this patch (in RESEND v6) unchanged so you can ack it there).

Thanks!

-- 
/manohar

  reply	other threads:[~2011-09-26 14:10 UTC|newest]

Thread overview: 15+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2011-09-01  9:15 [PATCH 0/3] [RESEND v5] VME Framework Fixes Manohar Vanga
2011-09-01  9:15 ` [PATCH 1/3] staging: vme: change static device array to pointers Manohar Vanga
2011-09-01  9:15 ` [PATCH 2/3] staging: vme: add struct vme_dev for VME devices Manohar Vanga
2011-09-02  9:02   ` Martyn Welch
2011-09-26 14:06     ` Manohar Vanga [this message]
2011-09-01  9:15 ` [PATCH 3/3] staging: vme: make match() driver specific to improve non-VME64x support Manohar Vanga
2011-09-01 22:26   ` Emilio G. Cota
2011-09-26 14:16     ` Manohar Vanga
2011-09-09 20:27 ` [PATCH 0/3] [RESEND v5] VME Framework Fixes Greg KH
  -- strict thread matches above, loose matches on Subject: below --
2011-08-31 10:05 [PATCH 0/3] [RESEND v4] " Manohar Vanga
2011-08-31 10:05 ` [PATCH 2/3] staging: vme: add struct vme_dev for VME devices Manohar Vanga
2011-08-29  9:02 [PATCH 0/3] [RESEND v3] VME Driver Changes Manohar Vanga
2011-08-29  9:02 ` [PATCH 2/3] staging: vme: add struct vme_dev for VME devices Manohar Vanga
2011-08-29 14:57   ` Emilio G. Cota
2011-08-29 17:52   ` Greg KH
2011-08-29 23:55     ` Emilio G. Cota
2011-08-30  7:52       ` Manohar Vanga

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20110926140655.GA16310@becoht-mvanga \
    --to=manohar.vanga@cern.ch \
    --cc=cota@braap.org \
    --cc=devel@driverdev.osuosl.org \
    --cc=gregkh@suse.de \
    --cc=linux-kernel@vger.kernel.org \
    --cc=martyn.welch@ge.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®