From: "Philippe Rétornaz" <philippe.retornaz@epfl.ch>
To: Fabio Estevam <festevam@gmail.com>
Cc: Heikki Krogerus <heikki.krogerus@linux.intel.com>,
Sascha Hauer <s.hauer@pengutronix.de>,
linux-usb@vger.kernel.org, linux-kernel@vger.kernel.org,
Peter Chen <peter.chen@freescale.com>,
"Lin Tony-B19295" <B19295@freescale.com>,
Alexander Shishkin <alexander.shishkin@linux.intel.com>,
Felipe Balbi <balbi@ti.com>, Greg KH <gregkh@suse.de>
Subject: Re: [PATCHv5 14/19] arm: imx: Start using struct usb_otg
Date: Tue, 4 Oct 2011 19:05:58 +0200 [thread overview]
Message-ID: <201110041905.59247.philippe.retornaz@epfl.ch> (raw)
In-Reply-To: <CAOMZO5DwDiBa_Ksow5bt02S_zMMEn4uB_hz-5KS+dyNiZA88sQ@mail.gmail.com>
Le lundi 3 octobre 2011 15:29:44, Fabio Estevam a écrit :
> On Mon, Oct 3, 2011 at 10:04 AM, Heikki Krogerus
>
> <heikki.krogerus@linux.intel.com> wrote:
> > Hi Sascha,
> >
> > On Mon, Sep 26, 2011 at 02:21:27PM +0300, Heikki Krogerus wrote:
> >> Use struct usb_otg members with OTG specific functions instead
> >> of usb_phy members.
> >>
> >> Includes fixes from Sascha Hauer.
> >>
> >> Signed-off-by: Heikki Krogerus <heikki.krogerus@linux.intel.com>
> >> Acked-by: Igor Grinberg <grinberg@compulab.co.il>
> >> Cc: Sascha Hauer <s.hauer@pengutronix.de>
> >
> > Have you had time to check it these work?
>
> Adding Philippe who has access to the mx31moboard-devboard and maybe
> could run a test?
Tested on mx31moboard-marxbot, works fine (ie, nothing changed).
BTW, totally unrelated, but I had to disable the sdma in order to boot
userspace on 3.1-rc8. It seems there is data corruption on sd card access with
the dma now.
Regards,
Philippe
next prev parent reply other threads:[~2011-10-04 17:06 UTC|newest]
Thread overview: 30+ messages / expand[flat|nested] mbox.gz Atom feed top
2011-09-26 11:21 [PATCHv5 00/19] First round in OTG rework Heikki Krogerus
2011-09-26 11:21 ` [PATCHv5 01/19] usb: otg: Rename otg_transceiver to usb_phy Heikki Krogerus
2011-09-26 11:21 ` [PATCHv5 02/19] usb: otg: Rename usb_otg and usb_xceiv " Heikki Krogerus
2011-09-26 11:21 ` [PATCHv5 03/19] usb: otg: Separate otg members from usb_phy Heikki Krogerus
2011-09-26 11:21 ` [PATCHv5 04/19] usb: otg: ab8500: Start using struct usb_otg Heikki Krogerus
2011-09-26 11:21 ` [PATCHv5 05/19] usb: otg: fsl: " Heikki Krogerus
2011-09-26 11:21 ` [PATCHv5 06/19] usb: otg: gpio_vbus: " Heikki Krogerus
2011-09-26 11:21 ` [PATCHv5 07/19] usb: otg: isp1301_omap: " Heikki Krogerus
2011-09-26 11:21 ` [PATCHv5 08/19] usb: otg: msm: " Heikki Krogerus
2011-09-26 11:21 ` [PATCHv5 09/19] usb: otg: langwell: " Heikki Krogerus
2011-09-26 11:21 ` [PATCHv5 10/19] usb: otg: nop: " Heikki Krogerus
2011-09-26 11:21 ` [PATCHv5 11/19] usb: otg: twl4030: " Heikki Krogerus
2011-09-26 11:21 ` [PATCHv5 12/19] usb: otg: twl6030: " Heikki Krogerus
2011-09-26 11:21 ` [PATCHv5 13/19] usb: otg: ulpi: " Heikki Krogerus
2011-10-24 12:28 ` Igor Grinberg
2011-09-26 11:21 ` [PATCHv5 14/19] arm: imx: " Heikki Krogerus
2011-10-03 13:04 ` Heikki Krogerus
2011-10-03 13:29 ` Fabio Estevam
2011-10-04 13:51 ` Philippe Rétornaz
2011-10-04 14:38 ` Heikki Krogerus
2011-10-04 17:05 ` Philippe Rétornaz [this message]
2011-10-05 9:51 ` Heikki Krogerus
2011-10-07 12:52 ` Sascha Hauer
2011-09-26 11:21 ` [PATCHv5 15/19] usb: musb: " Heikki Krogerus
2011-09-26 11:21 ` [PATCHv5 16/19] power_supply: Convert all users to new usb_phy Heikki Krogerus
[not found] ` <20111003131055.GC2487@xps8300>
2011-10-10 19:08 ` Anton Vorontsov
2011-10-24 10:14 ` Heikki Krogerus
2011-09-26 11:21 ` [PATCHv5 17/19] usb: " Heikki Krogerus
2011-09-26 11:21 ` [PATCHv5 18/19] usb: otg: Remove OTG specific members from usb_phy Heikki Krogerus
2011-09-26 11:21 ` [PATCHv5 19/19] usb: otg: Convert all users to pass struct usb_otg for OTG functions Heikki Krogerus
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=201110041905.59247.philippe.retornaz@epfl.ch \
--to=philippe.retornaz@epfl.ch \
--cc=B19295@freescale.com \
--cc=alexander.shishkin@linux.intel.com \
--cc=balbi@ti.com \
--cc=festevam@gmail.com \
--cc=gregkh@suse.de \
--cc=heikki.krogerus@linux.intel.com \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-usb@vger.kernel.org \
--cc=peter.chen@freescale.com \
--cc=s.hauer@pengutronix.de \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®