mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Jean-Christophe PLAGNIOL-VILLARD <plagnioj@jcrosoft.com>
To: Ryan Mallon <rmallon@gmail.com>
Cc: Nicolas Ferre <nicolas.ferre@atmel.com>,
	linux-arm-kernel@lists.infradead.org,
	linux-kernel@vger.kernel.org
Subject: Re: [PATCH 11/18] ARM: at91/rtc-at91sam9: each SoC can select the RTT device to use
Date: Mon, 20 Feb 2012 02:25:20 +0100	[thread overview]
Message-ID: <20120220012520.GB29599@game.jcrosoft.org> (raw)
In-Reply-To: <4F4194AB.40403@gmail.com>

On 11:32 Mon 20 Feb     , Ryan Mallon wrote:
> On 18/02/12 04:50, Nicolas Ferre wrote:
> 
> > From: Jean-Christophe PLAGNIOL-VILLARD <plagnioj@jcrosoft.com>
> > 
> > For the RTT as RTC driver rtc-at91sam9, the platform_device structure
> > is filled during SoC initialization. This will allow to convert this
> > RTC driver as a standard platform driver.
> > 
> > Signed-off-by: Jean-Christophe PLAGNIOL-VILLARD <plagnioj@jcrosoft.com>
> > Acked-by: Nicolas Ferre <nicolas.ferre@atmel.com>
> > ---
> >  arch/arm/mach-at91/at91sam9260_devices.c |   11 +++++
> >  arch/arm/mach-at91/at91sam9261_devices.c |   10 +++++
> >  arch/arm/mach-at91/at91sam9263_devices.c |   25 ++++++++++++
> >  arch/arm/mach-at91/at91sam9g45_devices.c |   10 +++++
> >  arch/arm/mach-at91/at91sam9rl_devices.c  |   10 +++++
> >  drivers/rtc/rtc-at91sam9.c               |   61 ++++-------------------------
> >  6 files changed, 75 insertions(+), 52 deletions(-)
> > 
> > diff --git a/arch/arm/mach-at91/at91sam9260_devices.c b/arch/arm/mach-at91/at91sam9260_devices.c
> > index b93a337..2071017 100644
> > --- a/arch/arm/mach-at91/at91sam9260_devices.c
> > +++ b/arch/arm/mach-at91/at91sam9260_devices.c
> > @@ -728,8 +728,19 @@ static struct platform_device at91sam9260_rtt_device = {
> >  	.num_resources	= ARRAY_SIZE(rtt_resources),
> >  };
> >  
> > +
> > +#if IS_ENABLED(CONFIG_RTC_DRV_AT91SAM9)
> > +static void __init at91_add_device_rtt_rtc(void)
> > +{
> > +	at91sam9260_rtt_device.name = "rtc-at91sam9";
> > +}
> 
> 
> Nitpickish: This function doesn't _add_ anything. It would probably be
> better called at91_init_device_rtt_rtc. Same goes for the other "add"
> functions in this patch.
yes but an other patch update it to add gpbr resource

> 
> > +#else
> > +static void __init at91_add_device_rtt_rtc(void) {}
> > +#endif
> > +
> >  static void __init at91_add_device_rtt(void)
> >  {
> > +	at91_add_device_rtt_rtc();
> >  	platform_device_register(&at91sam9260_rtt_device);
> >  }
> 
> 
> Does this work by setting the rtt device name iff
> CONFIG_RTC_DRV_AT91SAM9 is set? If so, it seems a bit ugly. Why bother
> doing the platform_device_register at all if you know it isn't going to
> do anything? Shouldn't the at91sam9260_rrt_device struct declaration and
> the platform_device_register all be conditional on CONFIG_RTC_DRV_AT91SAM9?
no people use rtt for other purpose
RTT is a timer and the rtc use it

anyway this will be dropped via DT
and the resource will be optional

Best Regards,
J.

  reply	other threads:[~2012-02-20  1:32 UTC|newest]

Thread overview: 43+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2012-02-17 17:49 [PATCH 00/18] at91 first cleanup series for 3.4 Nicolas Ferre
2012-02-17 17:49 ` [PATCH 01/18] ARM: at91: factorise duplicated at91sam9 idle Nicolas Ferre
2012-02-17 17:49   ` [PATCH 02/18] ARM: at91/at91x40: remove use of at91_sys_read/write Nicolas Ferre
2012-02-17 17:49   ` [PATCH 03/18] ARM: at91: make matrix register base soc independent Nicolas Ferre
2012-02-17 17:49   ` [PATCH 04/18] ARM: at91: make ST (System Timer) " Nicolas Ferre
2012-02-20  0:22     ` Ryan Mallon
2012-02-20  1:38       ` Jean-Christophe PLAGNIOL-VILLARD
2012-02-20  1:52         ` Ryan Mallon
2012-02-20  3:02           ` Jean-Christophe PLAGNIOL-VILLARD
2012-02-20  3:16             ` Ryan Mallon
2012-02-20  3:23               ` Jean-Christophe PLAGNIOL-VILLARD
2012-02-20  3:48                 ` Ryan Mallon
2012-02-20  3:49                   ` Jean-Christophe PLAGNIOL-VILLARD
2012-02-20  7:33             ` Russell King - ARM Linux
2012-02-20  9:18               ` Jean-Christophe PLAGNIOL-VILLARD
2012-02-17 17:49   ` [PATCH 05/18] ARM: at91/pm_slowclock: rename register to named define Nicolas Ferre
2012-02-17 17:49   ` [PATCH 06/18] ARM: at91/pm_slowclock: function slow_clock() accepts parameters Nicolas Ferre
2012-02-17 17:49   ` [PATCH 07/18] ARM: at91: move at91rm9200 sdramc defines to at91rm9200_sdramc.h Nicolas Ferre
2012-02-17 17:50   ` [PATCH 08/18] ARM: at91: make sdram/ddr register base soc independent Nicolas Ferre
2012-02-17 17:50   ` [PATCH 09/18] ARM: at91/pm_slowclock: add runtime detection of memory contoller Nicolas Ferre
2012-02-17 17:50   ` [PATCH 10/18] ARM: at91/PMC: make register base soc independent Nicolas Ferre
2012-02-20  0:27     ` Ryan Mallon
2012-02-17 17:50   ` [PATCH 11/18] ARM: at91/rtc-at91sam9: each SoC can select the RTT device to use Nicolas Ferre
2012-02-20  0:32     ` Ryan Mallon
2012-02-20  1:25       ` Jean-Christophe PLAGNIOL-VILLARD [this message]
2012-02-17 17:50   ` [PATCH 12/18] ARM: at91:rtc/rtc-at91sam9: ioremap register bank Nicolas Ferre
2012-02-17 17:50   ` [PATCH 13/18] ARM: at91/rtc-at91sam9: pass the GPBR to use via ressources Nicolas Ferre
2012-02-20  0:43     ` Ryan Mallon
2012-02-20  1:20       ` Jean-Christophe PLAGNIOL-VILLARD
2012-02-20  7:36         ` Russell King - ARM Linux
2012-02-20  9:16           ` Jean-Christophe PLAGNIOL-VILLARD
2012-02-20 10:04             ` Russell King - ARM Linux
2012-02-20 11:21               ` Nicolas Ferre
2012-02-20 14:45               ` [PATCH] ARM: at91/rtc-at91sam9: rework resources assignment Nicolas Ferre
2012-02-20 15:06                 ` Russell King - ARM Linux
2012-02-20 20:04                 ` Ryan Mallon
2012-02-17 17:50   ` [PATCH 14/18] ARM: at91: finally drop at91_sys_read/write Nicolas Ferre
2012-02-17 17:50   ` [PATCH 15/18] ARM: at91: merge SRAM Memory banks thanks to mirroring Nicolas Ferre
2012-02-17 17:50   ` [PATCH 16/18] Atmel: move console default platform_device to serial driver Nicolas Ferre
2012-02-18  9:17     ` Hans-Christian Egtvedt
2012-02-19  7:07       ` Jean-Christophe PLAGNIOL-VILLARD
2012-02-17 17:50   ` [PATCH 17/18] ARM: at91/board-dt: drop default console Nicolas Ferre
2012-02-17 17:50   ` [PATCH 18/18] ARM: at91/board-dt: move at91_initialize() to init_irq() Nicolas Ferre

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20120220012520.GB29599@game.jcrosoft.org \
    --to=plagnioj@jcrosoft.com \
    --cc=linux-arm-kernel@lists.infradead.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=nicolas.ferre@atmel.com \
    --cc=rmallon@gmail.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®