On Fri, Feb 10, 2012 at 03:40:36PM +0900, MyungJoo Ham wrote: > + [EXTCON_AUDIO_IN] = "Audio-in", > + [EXTCON_AUDIO_OUT] = "Audio-out", Can I suggest making these more specific - how about [EXTCON_LINE_IN] = "Line-in", [EXTCON_LINE_OUT] = "Line-out", [EXTCON_MIC_IN] = "Microphone", [EXTCON_HEADPHONE_OUT] = "Headphone", as a starting point? The distinction between line and the other two is often pretty important from a UI/system interaction point of view. > + /* TODO: remove before submit */ > + pr_info("[%s][%d]\n", buffer, enabled); :)