From: Jean-Christophe PLAGNIOL-VILLARD <plagnioj@jcrosoft.com>
To: Ryan Mallon <rmallon@gmail.com>
Cc: Nicolas Ferre <nicolas.ferre@atmel.com>,
linux-arm-kernel@lists.infradead.org,
linux-kernel@vger.kernel.org, linux@arm.linux.org.uk,
linux-usb@vger.kernel.org,
Greg Kroah-Hartman <gregkh@linuxfoundation.org>
Subject: Re: [PATCH v2 03/19] ARM: at91: make matrix register base soc independent
Date: Thu, 23 Feb 2012 04:26:18 +0100 [thread overview]
Message-ID: <20120223032618.GB20176@game.jcrosoft.org> (raw)
In-Reply-To: <4F456997.50500@gmail.com>
On 09:17 Thu 23 Feb , Ryan Mallon wrote:
> On 22/02/12 20:39, Nicolas Ferre wrote:
>
> > From: Jean-Christophe PLAGNIOL-VILLARD <plagnioj@jcrosoft.com>
> >
> > Signed-off-by: Jean-Christophe PLAGNIOL-VILLARD <plagnioj@jcrosoft.com>
> > Acked-by: Nicolas Ferre <nicolas.ferre@atmel.com>
> > Cc: linux-usb@vger.kernel.org
> > Cc: Greg Kroah-Hartman <gregkh@linuxfoundation.org>
>
>
> Looks okay, one comment (for future) below, but otherwise:
>
> Reviewed-by: Ryan Mallon <rmallon@gmail.com>
>
> <snip>
>
> > diff --git a/arch/arm/mach-at91/at91sam9263.c b/arch/arm/mach-at91/at91sam9263.c
> > index 8bdba2a..5fd6fe8 100644
> > --- a/arch/arm/mach-at91/at91sam9263.c
> > +++ b/arch/arm/mach-at91/at91sam9263.c
> > @@ -306,6 +306,7 @@ static void __init at91sam9263_ioremap_registers(void)
> > at91sam926x_ioremap_pit(AT91SAM9263_BASE_PIT);
> > at91sam9_ioremap_smc(0, AT91SAM9263_BASE_SMC0);
> > at91sam9_ioremap_smc(1, AT91SAM9263_BASE_SMC1);
> > + at91_ioremap_matrix(AT91SAM9263_BASE_MATRIX);
>
>
> Not necessarily for this patch set, but this list of functions is
> getting long enough that it could be abstracted away by a table.
> Something like:
>
> struct at91_sys_device {
> const char *name;
> void __iomem **base;
> const unsigned long mem_start;
> const unsigned long mem_size;
> };
>
> ...
>
> static const struct
> at91_sys_device at91sam9263_sys_devices[] __initconst = {
> {"PIT", &at91_pit_base,
> AT91SAM9263_BASE_PIT, AT91_PIT_SIZE},
> ...
> {"matrix", &at91_matrix_base,
> AT91SAM9263_BASE_MATRIX, AT91_MATRIX_SIZE},
> }
>
> ...
>
> void __init
> at91_ioremap_sys_devices(const struct at91_sys_device *devices,
> int nr_devices)
> {
> int i;
>
> for (i = 0; i < nr_devices; i++) {
> void __iomem *base = *(dev[i].base);
>
> base = ioremap(dev[i].mem_start, dev[i].mem_size);
> if (!base)
> panic("Impossible to ioremap AT91 %s\n",
> dev[i].name);
> }
we switch to the DT no need
Best Regards,
J.
next prev parent reply other threads:[~2012-02-23 3:34 UTC|newest]
Thread overview: 58+ messages / expand[flat|nested] mbox.gz Atom feed top
2012-02-22 9:39 [PATCH v2 00/19] at91 first cleanup series for 3.4 Nicolas Ferre
2012-02-22 9:39 ` [PATCH v2 01/19] ARM: at91: factorise duplicated at91sam9 idle Nicolas Ferre
2012-02-22 9:39 ` [PATCH v2 02/19] ARM: at91/at91x40: remove use of at91_sys_read/write Nicolas Ferre
2012-02-22 14:36 ` Arnd Bergmann
2012-02-22 16:26 ` Jean-Christophe PLAGNIOL-VILLARD
2012-02-22 22:22 ` Ryan Mallon
2012-02-23 3:25 ` Jean-Christophe PLAGNIOL-VILLARD
2012-02-23 3:59 ` Ryan Mallon
2012-02-23 6:01 ` Jean-Christophe PLAGNIOL-VILLARD
2012-02-23 9:23 ` Ryan Mallon
2012-02-22 9:39 ` [PATCH v2 03/19] ARM: at91: make matrix register base soc independent Nicolas Ferre
2012-02-22 22:17 ` Ryan Mallon
2012-02-23 3:26 ` Jean-Christophe PLAGNIOL-VILLARD [this message]
2012-02-22 9:39 ` [PATCH v2 04/19] ARM: at91: make ST (System Timer) " Nicolas Ferre
2012-02-22 22:24 ` Ryan Mallon
2012-02-22 9:39 ` [PATCH v2 05/19] ARM: at91/ST: remove not needed casts Nicolas Ferre
2012-02-22 22:24 ` Ryan Mallon
2012-02-22 9:39 ` [PATCH v2 06/19] ARM: at91/pm_slowclock: rename register to named define Nicolas Ferre
2012-02-22 9:50 ` Russell King - ARM Linux
2012-02-22 17:34 ` Jean-Christophe PLAGNIOL-VILLARD
2012-02-22 9:39 ` [PATCH v2 07/19] ARM: at91/pm_slowclock: function slow_clock() accepts parameters Nicolas Ferre
2012-02-22 9:52 ` Russell King - ARM Linux
2012-02-22 12:58 ` Jean-Christophe PLAGNIOL-VILLARD
2012-02-22 13:18 ` Russell King - ARM Linux
2012-02-22 13:57 ` Jean-Christophe PLAGNIOL-VILLARD
2012-02-22 9:39 ` [PATCH v2 08/19] ARM: at91: move at91rm9200 sdramc defines to at91rm9200_sdramc.h Nicolas Ferre
2012-02-22 9:39 ` [PATCH v2 09/19] ARM: at91: make sdram/ddr register base soc independent Nicolas Ferre
2012-02-22 22:33 ` Ryan Mallon
2012-02-23 8:56 ` Nicolas Ferre
2012-02-23 9:58 ` Nicolas Ferre
2012-02-23 10:51 ` Ryan Mallon
2012-02-23 13:47 ` Nicolas Ferre
2012-02-22 9:39 ` [PATCH v2 10/19] ARM: at91/pm_slowclock: add runtime detection of memory contoller Nicolas Ferre
2012-02-22 9:39 ` [PATCH v2 11/19] ARM: at91/PMC: make register base soc independent Nicolas Ferre
2012-02-22 22:50 ` Ryan Mallon
2012-02-23 8:38 ` Nicolas Ferre
2012-02-23 9:22 ` Ryan Mallon
2012-02-22 9:39 ` [PATCH v2 12/19] ARM: at91/rtc-at91sam9: each SoC can select the RTT device to use Nicolas Ferre
2012-02-22 14:50 ` Arnd Bergmann
2012-02-22 16:24 ` Jean-Christophe PLAGNIOL-VILLARD
2012-02-22 16:47 ` Arnd Bergmann
2012-02-22 17:07 ` Jean-Christophe PLAGNIOL-VILLARD
2012-02-22 17:25 ` Arnd Bergmann
2012-02-22 18:02 ` Jean-Christophe PLAGNIOL-VILLARD
2012-02-22 9:39 ` [PATCH v2 13/19] ARM: at91:rtc/rtc-at91sam9: ioremap register bank Nicolas Ferre
2012-02-22 9:39 ` [PATCH v2 14/19] ARM: at91/rtc-at91sam9: pass the GPBR to use via resources Nicolas Ferre
2012-02-22 9:39 ` [PATCH v2 15/19] ARM: at91: finally drop at91_sys_read/write Nicolas Ferre
2012-02-22 9:39 ` [PATCH v2 16/19] ARM: at91: merge SRAM Memory banks thanks to mirroring Nicolas Ferre
2012-02-22 23:13 ` Ryan Mallon
2012-02-23 3:28 ` Jean-Christophe PLAGNIOL-VILLARD
2012-02-22 9:39 ` [PATCH v2 17/19] Atmel: move console default platform_device to serial driver Nicolas Ferre
2012-02-22 9:39 ` [PATCH v2 18/19] ARM: at91/board-dt: drop default console Nicolas Ferre
2012-02-22 9:39 ` [PATCH v2 19/19] ARM: at91/board-dt: move at91_initialize() to init_irq() Nicolas Ferre
2012-02-22 9:48 ` Russell King - ARM Linux
2012-02-22 13:03 ` Jean-Christophe PLAGNIOL-VILLARD
2012-02-22 16:15 ` [PATCH 0/2] ARM: at91: two additional patches to cleanup series Nicolas Ferre
2012-02-22 16:15 ` [PATCH 1/2] ARM: at91: add at91sam9g25ek.dts in Makefile.boot Nicolas Ferre
2012-02-22 16:15 ` [PATCH 2/2] ARM: at91: properly sort dtb files " Nicolas Ferre
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20120223032618.GB20176@game.jcrosoft.org \
--to=plagnioj@jcrosoft.com \
--cc=gregkh@linuxfoundation.org \
--cc=linux-arm-kernel@lists.infradead.org \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-usb@vger.kernel.org \
--cc=linux@arm.linux.org.uk \
--cc=nicolas.ferre@atmel.com \
--cc=rmallon@gmail.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®