mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Jesse Barnes <jbarnes@virtuousgeek.org>
To: Yinghai Lu <yinghai@kernel.org>
Cc: Linus Torvalds <torvalds@linux-foundation.org>,
	linux-pci@vger.kernel.org, linux-kernel@vger.kernel.org
Subject: Re: [PATCH 4/4] PCI: acpihp user __pci_remove_bus_device instead
Date: Mon, 27 Feb 2012 12:19:32 -0800	[thread overview]
Message-ID: <20120227121932.24852506@jbarnes-desktop> (raw)
In-Reply-To: <1330206863-31381-5-git-send-email-yinghai@kernel.org>

[-- Attachment #1: Type: text/plain, Size: 1015 bytes --]

On Sat, 25 Feb 2012 13:54:23 -0800
Yinghai Lu <yinghai@kernel.org> wrote:

> pci_stop_bus_device get called before in the same loop.
> 
> Signed-off-by: Yinghai Lu <yinghai@kernel.org>
> 
> ---
>  drivers/pci/hotplug/acpiphp_glue.c |    2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)
> 
> Index: linux-2.6/drivers/pci/hotplug/acpiphp_glue.c
> ===================================================================
> --- linux-2.6.orig/drivers/pci/hotplug/acpiphp_glue.c
> +++ linux-2.6/drivers/pci/hotplug/acpiphp_glue.c
> @@ -910,7 +910,7 @@ static int disable_device(struct acpiphp
>  				disable_bridges(pdev->subordinate);
>  				pci_disable_device(pdev);
>  			}
> -			pci_stop_and_remove_bus_device(pdev);
> +			__pci_remove_bus_device(pdev);
>  			pci_dev_put(pdev);
>  		}
>  	}
> 

Ok applied these.  How about another that converts in-tree users to
pci_remove_bus_device and marks the __ version deprecated though?

-- 
Jesse Barnes, Intel Open Source Technology Center

[-- Attachment #2: signature.asc --]
[-- Type: application/pgp-signature, Size: 836 bytes --]

  reply	other threads:[~2012-02-27 20:19 UTC|newest]

Thread overview: 7+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2012-02-25 21:54 [PATCH 0/4] PCI: Rename pci_remove_* to pci_stop_and_remove_* Yinghai Lu
2012-02-25 21:54 ` [PATCH 1/4] PCI: Rename pci_remove_bus_device to pci_stop_and_remove_bus_device Yinghai Lu
2012-02-25 21:54 ` [PATCH 3/4] PCI: export __pci_remove_bus_device Yinghai Lu
2012-02-25 21:54 ` [PATCH 2/4] PCI: Rename pci_remove_behind_bridge to pci_stop_and_remove_behind_bridge Yinghai Lu
2012-02-25 21:54 ` [PATCH 4/4] PCI: acpihp user __pci_remove_bus_device instead Yinghai Lu
2012-02-27 20:19   ` Jesse Barnes [this message]
2012-02-27 20:43     ` Yinghai Lu

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20120227121932.24852506@jbarnes-desktop \
    --to=jbarnes@virtuousgeek.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-pci@vger.kernel.org \
    --cc=torvalds@linux-foundation.org \
    --cc=yinghai@kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

Powered by JetHome